码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 2039 To and Fro

时间:2016-09-02 06:28:11      阅读:168      评论:0      收藏:0      [点我收藏+]

标签:

To and Fro

Description

Mo and Larry have devised a way of encrypting messages. They first decide secretly on the number of columns and write the message (letters only) down the columns, padding with extra random letters so as to make a rectangular array of letters. For example, if the message is "There’s no place like home on a snowy night" and there are five columns, Mo would write down 
t o i o y

h p k n n
e l e a i
r a h s g
e c o n h
s e m o t
n l e w x

Note that Mo includes only letters and writes them all in lower case. In this example, Mo used the character "x" to pad the message out to make a rectangle, although he could have used any letter. 

Mo then sends the message to Larry by writing the letters in each row, alternating left-to-right and right-to-left. So, the above would be encrypted as 

toioynnkpheleaigshareconhtomesnlewx 

Your job is to recover for Larry the original message (along with any extra padding letters) from the encrypted one. 

Input

There will be multiple input sets. Input for each set will consist of two lines. The first line will contain an integer in the range 2. . . 20 indicating the number of columns used. The next line is a string of up to 200 lower case letters. The last input set is followed by a line containing a single 0, indicating end of input.

Output

Each input set should generate one line of output, giving the original plaintext message, with no spaces.

Sample Input

5
toioynnkpheleaigshareconhtomesnlewx
3
ttyohhieneesiaabss
0

Sample Output

theresnoplacelikehomeonasnowynightx
thisistheeasyoneab

#include<iostream>
#include<string>
using namespace std;
char a[400][400];

int main()
{
    string str;
    int column;

    while (cin >> column&&column != 0)
    {
        cin >> str;

        int row = str.length() / column ;
    
        for (int i = 0; i < row; i++)
            for (int j = 0; j < column; j++)
                a[i][j] = str[i*column + ((i % 2 == 0) ? (j) : (column - j - 1))];
    
        for (int i = 0; i < column; i++)
            for (int j = 0; j < row; ++j)
                cout << a[j][i];
    
        cout << endl;
    }

    return 0;
}

 



POJ 2039 To and Fro

标签:

原文地址:http://www.cnblogs.com/KennyRom/p/5831929.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!