码迷,mamicode.com
首页 > 其他好文 > 详细

hdu oj1102 Constructing Roads(最小生成树)

时间:2014-08-10 21:40:41      阅读:276      评论:0      收藏:0      [点我收藏+]

标签:最小生成树   acm   数据结构   

Constructing Roads

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13995    Accepted Submission(s): 5324


Problem Description
There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected. 

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.
 

Input
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.
 

Output
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum. 
 

Sample Input
3 0 990 692 990 0 179 692 179 0 1 1 2
 

Sample Output
179
 

Source
 
这道题和之前做的那道题类似,http://blog.csdn.net/whjkm/article/details/38471187 直接用prim再次水过 ,思想也和那道题类似,就是把两个已经连通的点之间的距离设为0就行了,然后再直接用prim水过;
下面是代码:
#include <cstdio>
#include <cstring>
using namespace std;
const int maxn=101;
const int Max=0x3f3f3f3f;
int map[maxn][maxn],low[maxn],visit[maxn];
int n;
int prim()
{
    int i,j,pos,min,mst=0;
    memset(visit,0,sizeof(visit));
    pos=1;
    visit[1]=1;
    for(i=1;i<=n;i++)
        low[i]=map[pos][i];
    for(i=1;i<n;i++)
    {
        min=Max;
        for(j=1;j<=n;j++)
        {
            if(!visit[j] && min>low[j])
            {
                min=low[j];
                pos=j;
            }
        }
        mst+=min;
        if(mst>=Max) break;//说明这个图不连通
        visit[pos]=j;
        for(j=1;j<=n;j++)
        {
            if(!visit[j] && low[j]>map[pos][j])//更新low数组
                low[j]=map[pos][j];
        }
    }
    return mst;
}
int main()
{
    int q,i,j;
    int a,b;
    while(scanf("%d",&n)!=EOF)
    {
        memset(map,Max,sizeof(map));
        for(i=1;i<=n;i++)
          for(j=1;j<=n;j++)
            scanf("%d",&map[i][j]);
        scanf("%d",&q);
       while(q--)
       {
           scanf("%d%d",&a,&b);
           map[a][b]=map[b][a]=0;
       }
       printf("%d\n",prim());
    }
    return 0;
}


hdu oj1102 Constructing Roads(最小生成树),布布扣,bubuko.com

hdu oj1102 Constructing Roads(最小生成树)

标签:最小生成树   acm   数据结构   

原文地址:http://blog.csdn.net/whjkm/article/details/38473077

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!