码迷,mamicode.com
首页 > 其他好文 > 详细

湖南省第十二届大学生计算机程序设计竞赛 A 2016

时间:2016-09-04 13:01:58      阅读:101      评论:0      收藏:0      [点我收藏+]

标签:

1803: 2016


Description

 

 

 给出正整数 n 和 m,统计满足以下条件的正整数对 (a,b) 的数量:

 

 

 

 

 
 

 

1. 1≤a≤n,1≤b≤m;

 

 

 

 

2. a×b 是 2016 的倍数。
 

Input

 

 

输入包含不超过 30 组数据。

 

 

 

 

每组数据包含两个整数 n,m (1≤n,m≤109).
 

Output

对于每组数据,输出一个整数表示满足条件的数量。

Sample Input

32 63
2016 2016
1000000000 1000000000

Sample Output

1
30576
7523146895502644

HINT

 题解:
  计算mod2016后 每对i,j对答案的贡献
#include<bits/stdc++.h>
using namespace std;

#pragma comment(linker, "/STACK:102400000,102400000")
#define ls i<<1
#define rs ls | 1
#define mid ((ll+rr)>>1)
#define pii pair<int,int>
#define MP make_pair

typedef long long LL;
const long long INF = 1e18;
const double Pi = acos(-1.0);
const int N = 2e5+10, M = 1e6+11, mod = 1e6+3, inf = 5000;

int n,m;
int main() {
        while(scanf("%d%d",&n,&m)!=EOF) {
                LL ans = 0;
                for(int i = 0; i <= 2015; ++i) {
                    for(int j = 0; j <= 2015; ++j) {
                        LL fi , se;
                         fi = n / 2016;
                        if( i && n%2016>=i) {fi++;}
                         se = m / 2016;
                        if(j && m%2016>=j) se++;
                        if(i*j % 2016 == 0) ans += fi*se;
                    }
                }
                cout<<ans<<endl;
        }
    return 0;
}

 

湖南省第十二届大学生计算机程序设计竞赛 A 2016

标签:

原文地址:http://www.cnblogs.com/zxhl/p/5839016.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!