码迷,mamicode.com
首页 > 其他好文 > 详细

POJ3624Charm Bracelet(01背包)

时间:2014-08-11 10:14:22      阅读:269      评论:0      收藏:0      [点我收藏+]

标签:01背包   acm   poj   

Charm Bracelet
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 23359   Accepted: 10532

Description

Bessie has gone to the mall‘s jewelry store and spies a charm bracelet. Of course, she‘d like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a ‘desirability‘ factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23

Source

还是01背包

#include<iostream>
#include<cstdio>
#include<cmath>
#include<queue>
#include<algorithm>
#include<cstring>
using namespace std;
int main()
{

    int n,i,j,v;
    while(scanf("%d%d",&n,&v)!=EOF){
        int dp[13000]={0},c[3500],w[3500];
        for(i=0;i<n;i++)
            scanf("%d%d",c+i,w+i);
        for(i=0;i<n;i++)
        {
            for(j=v;j>=c[i];j--)
            {
                if(dp[j]<dp[j-c[i]]+w[i])
                {
                    dp[j]=dp[j-c[i]]+w[i];
                }
            }
        }
        printf("%d\n",dp[v]);
    }
    return 0;
}


 

POJ3624Charm Bracelet(01背包),布布扣,bubuko.com

POJ3624Charm Bracelet(01背包)

标签:01背包   acm   poj   

原文地址:http://blog.csdn.net/fljssj/article/details/38486651

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!