码迷,mamicode.com
首页 > 其他好文 > 详细

HDU2602Bone Collector

时间:2014-08-11 10:15:12      阅读:242      评论:0      收藏:0      [点我收藏+]

标签:hdu acm 01背包

Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 29685    Accepted Submission(s): 12208


Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
bubuko.com,布布扣

 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the maximum of the total value (this number will be less than 231).
 

Sample Input
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output
14
 
简单01背包
#include<iostream>
#include<cstdio>
#include<cmath>
#include<queue>
#include<algorithm>
#include<cstring>
using namespace std;
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,i,j,v;
        scanf("%d%d",&n,&v);
        int dp[1100]={0},c[1100],w[1100];
        for(i=0;i<n;i++)
            scanf("%d",w+i);
        for(i=0;i<n;i++)
            scanf("%d",c+i);
        for(i=0;i<n;i++)
        {
            for(j=v;j>=c[i];j--)
            {
                if(dp[j]<dp[j-c[i]]+w[i])
                {
                    dp[j]=dp[j-c[i]]+w[i];
                }
            }
        }
        printf("%d\n",dp[v]);
    }
    return 0;
}



HDU2602Bone Collector,布布扣,bubuko.com

HDU2602Bone Collector

标签:hdu acm 01背包

原文地址:http://blog.csdn.net/fljssj/article/details/38486533

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!