码迷,mamicode.com
首页 > 其他好文 > 详细

ACdream 1007 (快速幂)

时间:2014-08-11 11:24:42      阅读:198      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   java   os   io   

题目链接

a + b

Time Limit: 2000/1000MS (Java/Others)Memory Limit: 128000/64000KB (Java/Others)

Problem Description

bubuko.com,布布扣

Input

bubuko.com,布布扣

Output

bubuko.com,布布扣

Sample Input

2
3 1
1 2 3
3 10
1 2 3

Sample Output

6
60074

/*************************************************************************
    > File Name: 1007.cpp
    > Author: Stomach_ache
    > Mail: sudaweitong@gmail.com
    > Created Time: 2014年08月11日 星期一 07时44分39秒
    > Propose: 
 ************************************************************************/
#include <cstdio>
/*Let‘s fight!!!*/

typedef long long LL;
const LL mod = (LL)1e10 + 7;

LL mul(LL a, LL b) {
      LL res = 0;
    while (b) {
          if (b&1) if ((res += a) >= mod) res -= mod;
        a <<= 1;
        if (a >= mod) a -= mod;
        b >>= 1;
    }
    return res;
}

LL mod_pow(LL a, LL b) {
      LL res = 1;
    while (b) {
          if (b&1) res = mul(res, a);
        a = mul(a, a);
        b >>= 1;
    }
    return res;
}

int main(void) {
    int t;
    scanf("%d", &t);
    while (t--) {
        LL n, k, ans = 0, x;
        scanf("%lld %lld", &n, &k);
        k %= 9560995488LL;

        for (int i = 0; i < n; i++) {
            scanf("%lld", &x);
            ans += mod_pow((x%mod+mod)%mod, k);
            if (ans >= mod) ans -= mod; 
        }

        printf("%lld\n", ans);
    }

    return 0;
}

 


ACdream 1007 (快速幂),布布扣,bubuko.com

ACdream 1007 (快速幂)

标签:des   style   blog   http   color   java   os   io   

原文地址:http://www.cnblogs.com/Stomach-ache/p/3904074.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!