码迷,mamicode.com
首页 > 其他好文 > 详细

POJ2407(欧拉函数)

时间:2016-09-07 12:50:15      阅读:122      评论:0      收藏:0      [点我收藏+]

标签:

Relatives
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 13693   Accepted: 6834

Description

Given n, a positive integer, how many positive integers less than n are relatively prime to n? Two integers a and b are relatively prime if there are no integers x > 1, y > 0, z > 0 such that a = xy and b = xz.

Input

There are several test cases. For each test case, standard input contains a line with n <= 1,000,000,000. A line containing 0 follows the last case.

Output

For each test case there should be single line of output answering the question posed above.

Sample Input

7
12
0

Sample Output

6
4

欧拉函数入门。
#include <cstdio>
using namespace std;
int euler(int n)
{
    int ret=n;
    for(int i=2;i*i<=n;i++)
    {
        if(n%i==0)
        {
            ret=ret-ret/i;
            while(n%i==0)    n/=i;
                
        }
    }
    if(n>1)    ret=ret-ret/n;
    return ret;
}
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF&&n!=0)
    {
        int res=euler(n);
        printf("%d\n",res);
    }
    return 0;
}

 

 


 

POJ2407(欧拉函数)

标签:

原文地址:http://www.cnblogs.com/program-ccc/p/5848886.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!