码迷,mamicode.com
首页 > 其他好文 > 详细

poj 1195 单点更新 区间求和

时间:2014-08-11 11:47:52      阅读:230      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   java   os   io   

Mobile phones

Time Limit: 5000 MS Memory Limit: 65536 KB

64-bit integer IO format: %I64d , %I64u Java class name: Main

[Submit] [Status] [Discuss]

Description

Suppose that the fourth generation mobile phone base stations in the Tampere area operate as follows. The area is divided into squares. The squares form an S * S matrix with the rows and columns numbered from 0 to S-1. Each square contains a base station. The number of active mobile phones inside a square can change because a phone is moved from a square to another or a phone is switched on or off. At times, each base station reports the change in the number of active phones to the main base station along with the row and the column of the matrix.

Write a program, which receives these reports and answers queries about the current total number of active mobile phones in any rectangle-shaped area.

Input

The input is read from standard input as integers and the answers to the queries are written to standard output as integers. The input is encoded as follows. Each input comes on a separate line, and consists of one instruction integer and a number of parameter integers according to the following table.
bubuko.com,布布扣

The values will always be in range, so there is no need to check them. In particular, if A is negative, it can be assumed that it will not reduce the square value below zero. The indexing starts at 0, e.g. for a table of size 4 * 4, we have 0 <= X <= 3 and 0 <= Y <= 3.

Table size: 1 * 1 <= S * S <= 1024 * 1024
Cell value V at any time: 0 <= V <= 32767
Update amount: -32768 <= A <= 32767
No of instructions in input: 3 <= U <= 60002
Maximum number of phones in the whole table: M= 2^30

Output

Your program should not answer anything to lines with an instruction other than 2. If the instruction is 2, then your program is expected to answer the query by writing the answer as a single line containing a single integer to standard output.

Sample Input

0 4
1 1 2 3
2 0 0 2 2 
1 1 1 2
1 1 2 -1
2 1 1 2 3 
3

Sample Output

3
4

 #include <iostream>
 #include <string.h>
 #include <stdio.h>

 using namespace std;
 #define max 1025
 int c[max][max];
 int n;

 int lowbit(int x)
 {
     return x&-x;
 }

 void update(int x,int y,int val)
 {
     for(int i=x;i<=n;i+=lowbit(i))
     {
         for(int j=y;j<=n;j+=lowbit(j))
         {
             c[i][j]+=val;
         }
     }
 }

int get_sum(int x,int y)
 {
     int s=0;
     for(int i=x;i>0;i-=lowbit(i))
     {
         for(int j=y;j>0;j-=lowbit(j))
         {
             s+=c[i][j];
         }
     }
     return s;
 }

 int main()
    {
        int i,j,s,T,x,y,x1,y1,val;
        while(1)
        {
            scanf("%d",&T);
            if (T==3) break;
            if (T==0)
            {
                scanf("%d",&n);
                memset(c,0,sizeof(c));
            }
            if (T==1)
            {
                scanf("%d%d%d",&x,&y,&val);
                update(x+1,y+1,val);   ///脚标从0开始  所以要+1喽~~~~
            }
            if (T==2)
            {
                scanf("%d%d%d%d",&x,&y,&x1,&y1);  ///同理
                printf("%d\n",get_sum(x1+1,y1+1)+get_sum(x,y)-get_sum(x1+1,y)-get_sum(x,y1+1));
            }
        }
        return 0;
    }

 

poj 1195 单点更新 区间求和,布布扣,bubuko.com

poj 1195 单点更新 区间求和

标签:des   style   blog   http   color   java   os   io   

原文地址:http://www.cnblogs.com/zhangying/p/3904196.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!