码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 4932 Miaomiao's Geometry 暴力

时间:2014-08-11 12:10:12      阅读:259      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   color   java   os   io   strong   


Miaomiao‘s Geometry

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 438    Accepted Submission(s): 107


Problem Description
There are N point on X-axis . Miaomiao would like to cover them ALL by using segments with same length.

There are 2 limits:

1.A point is convered if there is a segments T , the point is the left end or the right end of T.
2.The length of the intersection of any two segments equals zero.

For example , point 2 is convered by [2 , 4] and not convered by [1 , 3]. [1 , 2] and [2 , 3] are legal segments , [1 , 2] and [3 , 4] are legal segments , but [1 , 3] and [2 , 4] are not (the length of intersection doesn‘t equals zero), [1 , 3] and [3 , 4] are not(not the same length).

Miaomiao wants to maximum the length of segements , please tell her the maximum length of segments.

For your information , the point can‘t coincidently at the same position.
 

Input
There are several test cases.
There is a number T ( T <= 50 ) on the first line which shows the number of test cases.
For each test cases , there is a number N ( 3 <= N <= 50 ) on the first line.
On the second line , there are N integers Ai (-1e9 <= Ai <= 1e9) shows the position of each point.
 

Output
For each test cases , output a real number shows the answser. Please output three digit after the decimal point.
 

Sample Input
3 3 1 2 3 3 1 2 4 4 1 9 100 10
 

Sample Output
1.000 2.000 8.000
Hint
For the first sample , a legal answer is [1,2] [2,3] so the length is 1. For the second sample , a legal answer is [-1,1] [2,4] so the answer is 2. For the thired sample , a legal answer is [-7,1] , [1,9] , [10,18] , [100,108] so the answer is 8.
 

Source
 

有n个点在x坐标上,要求用一些线段将这些点全部覆盖,要求这些线段不能重叠,且必须等长,x坐标上的点必须在线段的端点,求线段的最长长度。
一开始从第二个点到倒数第二个点找左右距离最大的值存到数组里面,最后输出此数组最小的即可,也就是求个最大最小。但是如果数据是这样的:2 7 8 14 15的话,果断WA,因为8和14共用一段区间,且此区间要大于2-7的5,。
正确解法应该是从大到小枚举将这些数的差值以及差值的一半,如果符合要求,则就是答案。

//15MS	268K
#include<stdio.h>
#include<algorithm>
using namespace std;
double s[57],array[107];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,k=0;
        scanf("%d",&n);
        for(int i=0;i<n;i++)
            scanf("%lf",&s[i]);
        sort(s,s+n);
        for(int i=1;i<n;i++)
        {
            array[k++]=s[i]-s[i-1];
            array[k++]=(s[i]-s[i-1])/2;
        }
        sort(array,array+k);
        for(int i=k-1;i>=0;i--)
        {
            bool flag=1;
            double last=s[0],a=array[i];
            for(int j=1;j<n-1;j++)
            {
                if(last==s[j])continue;
                if(last+a<=s[j])last=s[j];
                else if(s[j]+a<=s[j+1])last=s[j]+a;
                else {flag=0;break;}
            }
            if(flag){printf("%.3lf\n",a);break;}
        }
    }
    return 0;
}


HDU 4932 Miaomiao's Geometry 暴力,布布扣,bubuko.com

HDU 4932 Miaomiao's Geometry 暴力

标签:des   style   http   color   java   os   io   strong   

原文地址:http://blog.csdn.net/crescent__moon/article/details/38487785

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!