码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 2533 Longest Ordered Subsequence(LIS模版题)

时间:2016-09-08 18:27:41      阅读:123      评论:0      收藏:0      [点我收藏+]

标签:

Longest Ordered Subsequence
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 47465   Accepted: 21120

Description

A numeric sequence of ai is ordered if a1 < a2 < ... < aN. Let the subsequence of the given numeric sequence (a1a2, ..., aN) be any sequence (ai1ai2, ..., aiK), where 1 <= i1 < i2< ... < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4

 

 

题目链接:POJ 2533

LIS模版题,N2和N*logN两种写法

N2代码:

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<cstdlib>
#include<sstream>
#include<cstring>
#include<bitset>
#include<string>
#include<deque>
#include<stack>
#include<cmath>
#include<queue>
#include<set>
#include<map>
using namespace std;
#define INF 0x3f3f3f3f
#define CLR(x,y) memset(x,y,sizeof(x))
#define LC(x) (x<<1)
#define RC(x) ((x<<1)+1)
#define MID(x,y) ((x+y)>>1)
typedef pair<int,int> pii;
typedef long long LL;
const double PI=acos(-1.0);
const int N=1e3+10;
int arr[N],mx[N];
void init()
{
    CLR(arr,0);
    CLR(mx,0);
}
int main(void)
{
    int n,i,j,pre_len,next_len;
    while (~scanf("%d",&n))
    {
        init();
        for (i=1; i<=n; ++i)
            scanf("%d",&arr[i]);
        mx[1]=1;
        for (i=2; i<=n; ++i)
        {
            pre_len=0;
            for (j=1; j<i; ++j)
            {
                if(arr[j]<arr[i])//arr[i]可以接到arr[j]后面
                    if(mx[j]>pre_len)//接到一个具有最长LIS的后面。
                        pre_len=mx[j];
            }
            mx[i]=pre_len+1;
        }
        printf("%d\n",*max_element(mx+1,mx+1+n));
    }
    return 0;
}

 

 

NlogN代码:

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<cstdlib>
#include<sstream>
#include<cstring>
#include<bitset>
#include<string>
#include<deque>
#include<stack>
#include<cmath>
#include<queue>
#include<set>
#include<map>
using namespace std;
#define INF 0x3f3f3f3f
#define CLR(x,y) memset(x,y,sizeof(x))
#define LC(x) (x<<1)
#define RC(x) ((x<<1)+1)
#define MID(x,y) ((x+y)>>1)
typedef pair<int,int> pii;
typedef long long LL;
const double PI=acos(-1.0);
const int N=1e3+10;
int arr[N],d[N];
void init()
{
    CLR(arr,0);
    CLR(d,0);
}
int main(void)
{
    int n,i,j,mxlen;
    while (~scanf("%d",&n))
    {
        init();
        for (i=1; i<=n; ++i)
            scanf("%d",&arr[i]);

        mxlen=1;
        d[mxlen]=arr[mxlen];

        for (i=2; i<=n; ++i)
        {
            if(d[mxlen]<arr[i])
                d[++mxlen]=arr[i];//最好情况一直往后增长
            else
            {
                int pos=lower_bound(d,d+mxlen,arr[i])-d;//用二分找到一个下界可放置位置
                d[pos]=arr[i];
            }
        }
        printf("%d\n",mxlen);
    }
    return 0;
}

 

POJ 2533 Longest Ordered Subsequence(LIS模版题)

标签:

原文地址:http://www.cnblogs.com/Blackops/p/5853673.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!