码迷,mamicode.com
首页 > 其他好文 > 详细

poj 2299 Ultra-QuickSort

时间:2016-09-08 19:53:48      阅读:150      评论:0      收藏:0      [点我收藏+]

标签:

Ultra-QuickSort
Time Limit: 7000MS   Memory Limit: 65536K
Total Submissions: 56054   Accepted: 20706

Description

技术分享In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence
9 1 0 5 4 ,

Ultra-QuickSort produces the output
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0

Source

/*
数据结构好神奇!!!
树状数组:将每个下标用二进制表示末尾有k个连续0,那么这个坐标盛放的数值就是2^k个数的和,就是从这个数往前数2^k的和。
这个题先把数据离散化,所谓离散化呐,我现在的理解就是数据处理一下,使得内存占用小一点,对数列优化一下。
这个题的优化就是对数据先进行排序,知道大小关系之后就不需要管这些数据了,然后在树中找每个数前面有多少比他小的数然后求和。
*/
#include<iostream>
#include<stdio.h>
#include<string.h>
#include<string>
#include<algorithm>
#define N 500010
using namespace std;
struct node 
{
    long long val;
    long long ip;
}fr[N];
bool comp(node a,node b)
{
    return a.val<b.val;
}
long long n;
long long c[N];//记录每个节点的和
long long index[N];//记录每个节点的和的下标
long long lowbit(long long x)
{
    return x&(-x);
}
long long getx(long long x)
{
    long long ans=0;
    while(x>=1)
    {
        ans+=c[x];
        x-=lowbit(x);
    }
    return ans;
}
void update(long long x)
{
    while(x<=n)
    {
        c[x]+=1;
        x+=lowbit(x);
    }
}
int main()
{   
    //freopen("in.txt","r",stdin);
    while(scanf("%lld",&n)!=EOF&&n)
    {
        for(int i=1;i<=n;i++)
        {
            scanf("%lld",&fr[i].val);
            fr[i].ip=i;
        }    
        sort(fr+1,fr+n+1,comp);
        for(int i=1;i<=n;i++)
            index[fr[i].ip]=i;
        for(int i=1;i<=n;i++) c[i]=0;
        long long cur=0;
        for(int i=1;i<=n;i++)
        {
            update(index[i]);
            //cout<<getx(index[i])<<" ";
            cur+=(i-getx(index[i]));
        }    
        //cout<<endl;
        printf("%lld\n",cur);
    }
    return 0;
}
/*
                   _ooOoo_
                  o8888888o
                  88" . "88
                  (| -_- |)
                  O\  =  /O
               ____/`---‘\____
             .‘  \\|     |//  `.
            /  \\|||  :  |||//             /  _||||| -:- |||||-             |   | \\\  -  /// |   |
           | \_|  ‘‘\---/‘‘  |   |
           \  .-\__  `-`  ___/-. /
         ___`. .‘  /--.--\  `. . __
      ."" ‘<  `.___\_<|>_/___.‘  >‘"".
     | | :  `- \`.;`\ _ /`;.`/ - ` : | |
     \  \ `-.   \_ __\ /__ _/   .-` /  /
======`-.____`-.___\_____/___.-`____.-‘======
                   `=---=‘
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
         I have a dream!A AC deram!!
 orz orz orz orz orz orz orz orz orz orz orz
 orz orz orz orz orz orz orz orz orz orz orz
 orz orz orz orz orz orz orz orz orz orz orz

*/

 

poj 2299 Ultra-QuickSort

标签:

原文地址:http://www.cnblogs.com/wuwangchuxin0924/p/5854131.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!