码迷,mamicode.com
首页 > 其他好文 > 详细

bzoj 1677: [Usaco2005 Jan]Sumsets 求和

时间:2016-09-08 19:57:23      阅读:134      评论:0      收藏:0      [点我收藏+]

标签:

Description

Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7: 1) 1+1+1+1+1+1+1 2) 1+1+1+1+1+2 3) 1+1+1+2+2 4) 1+1+1+4 5) 1+2+2+2 6) 1+2+4 Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000).

给出一个N(1≤N≤10^6),使用一些2的若干次幂的数相加来求之.问有多少种方法

Input

   一个整数N.

Output

方法数.这个数可能很大,请输出其在十进制下的最后9位.

Sample Input

7

Sample Output

6

有以下六种方式
1) 1+1+1+1+1+1+1
2) 1+1+1+1+1+2
3) 1+1+1+2+2
4) 1+1+1+4
5) 1+2+2+2
6) 1+2+4

HINT

 

Source

#include<cstdio>
#define mod 1000000000
#define F(i,l,r) for(int i=l;i<=r;i++)
int dp[1000010],n;
int main()
{
	dp[1]=1;
	scanf("%d",&n);
	F(i,2,n)
	{
		if(i&1) dp[i]=dp[i-1];
		else dp[i]=(dp[i-1]+dp[i>>1])%mod;
	}
	printf("%d",dp[n]);
} 

  

bzoj 1677: [Usaco2005 Jan]Sumsets 求和

标签:

原文地址:http://www.cnblogs.com/lkhll/p/5854175.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!