码迷,mamicode.com
首页 > 其他好文 > 详细

hdu1213 How Many Tables

时间:2014-08-11 14:39:52      阅读:179      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   java   os   io   

How Many Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13476    Accepted Submission(s): 6608

Problem Description

Today is Ignatius‘ birthday. He invites a lot of friends. Now it‘s dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.
One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.
For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

Input

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

Output

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

Sample Input

2 5 3 1 2 2 3 4 5 5 1 2 5

Sample Output

2 4

Author

Ignatius.L

Source

杭电ACM省赛集训队选拔赛之热身赛

 

思路:并查集,统计集合个数

 

#include<cstdio>
#include<cstring>
#include<iostream>
#include<string>
#include<algorithm>
using namespace std;

const int maxn=1000+5;
int p[maxn];
int n,m;
int ans;

void make_set()
{
    for(int i=0;i<=n;i++)
        p[i]=i;
}

int find_set(int x)
{
    return p[x]!=x ? p[x]=find_set(p[x]) : x;
}

void union_set(int x, int y)
{
    int fx=find_set(x), fy=find_set(y);
    if(fx!=fy)
    {
        p[fx]=fy;
    }
}

int main()
{
    int T;
    scanf("%d", &T);
    while(T--) {
        scanf("%d%d", &n, &m);
        make_set();
        for(int i=0;i<m;i++) {
            int x,y; scanf("%d%d", &x, &y);
            union_set(x, y);
        }
        ans=0;
        for(int i=1;i<=n;i++) if(p[i]==i) ans++;
        printf("%d\n", ans);
    }

    return 0;
}

hdu1213 How Many Tables,布布扣,bubuko.com

hdu1213 How Many Tables

标签:des   style   blog   http   color   java   os   io   

原文地址:http://www.cnblogs.com/cute/p/3904492.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!