码迷,mamicode.com
首页 > 其他好文 > 详细

ZOJ3469:Food Delivery(区间DP)

时间:2014-08-11 15:02:22      阅读:333      评论:0      收藏:0      [点我收藏+]

标签:dp   zoj   

When we are focusing on solving problems, we usually prefer to stay in front of computers rather than go out for lunch. At this time, we may call for food delivery.

Suppose there are N people living in a straight street that is just lies on an X-coordinate axis. The ith person‘s coordinate is Xi meters. And in the street there is a take-out restaurant which has coordinates X meters. One day at lunchtime, each person takes an order from the restaurant at the same time. As a worker in the restaurant, you need to start from the restaurant, send food to the N people, and then come back to the restaurant. Your speed is V-1 meters per minute.

You know that the N people have different personal characters; therefore they have different feeling on the time their food arrives. Their feelings are measured by Displeasure Index. At the beginning, the Displeasure Index for each person is 0. When waiting for the food, the ith person will gain Bi Displeasure Index per minute.

If one‘s Displeasure Index goes too high, he will not buy your food any more. So you need to keep the sum of all people‘s Displeasure Index as low as possible in order to maximize your income. Your task is to find the minimal sum of Displeasure Index.

Input

The input contains multiple test cases, separated with a blank line. Each case is started with three integers N ( 1 <= N <= 1000 ), V ( V > 0), X ( X >= 0 ), then N lines followed. Each line contains two integers Xi ( Xi >= 0 ), Bi ( Bi >= 0), which are described above.

You can safely assume that all numbers in the input and output will be less than 231 - 1.

Please process to the end-of-file.

Output

For each test case please output a single number, which is the minimal sum of Displeasure Index. One test case per line.

Sample Input

5 1 0
1 1
2 2
3 3
4 4
5 5

Sample Output

55


一个逗比送外卖,一群顾客逗比因为等的时间增长而不满值也增强,求不满值的最小值

dp[i][j][k]表示i~j区间内外卖送完后的最小不满值,k=0表示停在i点,k=1表示停在j点

然后得到四个状态转移

 dp[i][j][0]=min(dp[i][j][0],dp[i+1][j][0]+(a[i+1].x-a[i].x)*(tem+a[i].v));
 dp[i][j][0]=min(dp[i][j][0],dp[i+1][j][1]+(a[j].x-a[i].x)*(tem+a[i].v));
 dp[i][j][1]=min(dp[i][j][1],dp[i][j-1][0]+(a[j].x-a[i].x)*(tem+a[j].v));
 dp[i][j][1]=min(dp[i][j][1],dp[i][j-1][1]+(a[j].x-a[j-1].x)*(tem+a[j].v));


#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
#define up(i,x,y) for(i=x;i<=y;i++)
#define down(i,x,y) for(i=x;i>=y;i--)
#define mem(a,b) memset(a,b,sizeof(a))
#define w(x) while(x)
const int inf = 1<<30;
int dp[1005][1005][2],sum[1005];

struct node
{
    int x,v;
} a[1005];

int cmp(node a,node b)
{
    return a.x<b.x;
}

int set(int l,int r)
{
    if(l>r) return 0;
    return sum[r]-sum[l-1];
}

int main()
{
    int n,v,x,i,j,k,pos,tem;
    w(~scanf("%d%d%d",&n,&v,&x))
    {
        up(i,1,n)
        scanf("%d%d",&a[i].x,&a[i].v);
        n++;
        a[n].x=x,a[n].v=0;
        sort(a+1,a+n+1,cmp);
        up(i,1,n)
        sum[i]=sum[i-1]+a[i].v;
        up(i,1,n)
        up(j,1,n)
        dp[i][j][0]=dp[i][j][1]=inf;
        up(i,1,n)
        if(a[i].x==x)
        {
            pos=i;
            break;
        }
        dp[pos][pos][0]=dp[pos][pos][1]=sum[0]=0;
        down(i,pos,1)
        {
            up(j,pos,n)
            {
                tem=set(1,i-1)+set(j+1,n);
                if(i==j) continue;
                dp[i][j][0]=min(dp[i][j][0],dp[i+1][j][0]+(a[i+1].x-a[i].x)*(tem+a[i].v));
                dp[i][j][0]=min(dp[i][j][0],dp[i+1][j][1]+(a[j].x-a[i].x)*(tem+a[i].v));
                dp[i][j][1]=min(dp[i][j][1],dp[i][j-1][0]+(a[j].x-a[i].x)*(tem+a[j].v));
                dp[i][j][1]=min(dp[i][j][1],dp[i][j-1][1]+(a[j].x-a[j-1].x)*(tem+a[j].v));
            }
        }
        printf("%d\n",min(dp[1][n][0],dp[1][n][1])*v);
    }


    return 0;
}


ZOJ3469:Food Delivery(区间DP),布布扣,bubuko.com

ZOJ3469:Food Delivery(区间DP)

标签:dp   zoj   

原文地址:http://blog.csdn.net/libin56842/article/details/38492405

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!