码迷,mamicode.com
首页 > 其他好文 > 详细

Chocolate_DP

时间:2016-09-11 00:00:12      阅读:438      评论:0      收藏:0      [点我收藏+]

标签:

Description

In 2100, ACM chocolate will be one of the favorite foods in the world. 

"Green, orange, brown, red...", colorful sugar-coated shell maybe is the most attractive feature of ACM chocolate. How many colors have you ever seen? Nowadays, it‘s said that the ACM chooses from a palette of twenty-four colors to paint their delicious candy bits. 

One day, Sandy played a game on a big package of ACM chocolates which contains five colors (green, orange, brown, red and yellow). Each time he took one chocolate from the package and placed it on the table. If there were two chocolates of the same color on the table, he ate both of them. He found a quite interesting thing that in most of the time there were always 2 or 3 chocolates on the table. 

Now, here comes the problem, if there are C colors of ACM chocolates in the package (colors are distributed evenly), after N chocolates are taken from the package, what‘s the probability that there is exactly M chocolates on the table? Would you please write a program to figure it out? 

Input

The input file for this problem contains several test cases, one per line. 

For each case, there are three non-negative integers: C (C <= 100), N and M (N, M <= 1000000). 

The input is terminated by a line containing a single zero. 

Output

The output should be one real number per line, shows the probability for each case, round to three decimal places.

Sample Input

5 100 2

0

Sample Output

0.625 

 

 

【题意】给出c,n,m代表c种颜色的糖,从袋子里拿出n颗,放在桌子上,如果已经相同颜色,就把两颗都吃掉,问最后桌子剩m颗的概率

【思路】dp,dp[i][j]=dp[i-1][j-1]*(c-j+1)/c+dp[i-1][j+1]*(j+1)/c;

剪枝,m不可能大于n和c,并且n和m同奇同偶;

#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
int main()
{
    double dp[1010][110];
    int c,n,m;
    while(cin>>c,c)
    {
        scanf("%d%d",&n,&m);
        if(m>c||m>n||(n+m)&1)
        {
            printf("0.000\n");
            continue;
        }
        if(n>1000)
            n=1000+(n&1);
        memset(dp,0,sizeof(dp));
        dp[0][0]=1;
        for(int i=1;i<=n;i++)
        {
            dp[i][0]=dp[i-1][1]/c;
            dp[i][c]=dp[i-1][c-1]/c;
            for(int j=1;j<c;j++)
            {
                dp[i][j]=dp[i-1][j-1]*(double)(c-j+1)/c+dp[i-1][j+1]*(double)(j+1)/c;
            }
        }
        printf("%.3f\n",dp[n][m]);
    }
    return 0;
}

 

Chocolate_DP

标签:

原文地址:http://www.cnblogs.com/iwantstrong/p/5860559.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!