码迷,mamicode.com
首页 > 其他好文 > 详细

杭电 2710(水题)

时间:2014-08-11 17:52:32      阅读:245      评论:0      收藏:0      [点我收藏+]

标签:杭电

Max Factor

<span size="+0"><strong><span style="font-family:Arial;font-size:12px;color:green;FONT-WEIGHT: bold">Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3693    Accepted Submission(s): 1181
</span></strong></span>

Problem Description
To improve the organization of his farm, Farmer John labels each of his N (1 <= N <= 5,000) cows with a distinct serial number in the range 1..20,000. Unfortunately, he is unaware that the cows interpret some serial numbers as better than others. In particular, a cow whose serial number has the highest prime factor enjoys the highest social standing among all the other cows.

(Recall that a prime number is just a number that has no divisors except for 1 and itself. The number 7 is prime while the number 6, being divisible by 2 and 3, is not).

Given a set of N (1 <= N <= 5,000) serial numbers in the range 1..20,000, determine the one that has the largest prime factor.
 
<span style="font-size:14px;">
</span>
Input
* Line 1: A single integer, N

* Lines 2..N+1: The serial numbers to be tested, one per line
 
<span style="font-size:14px;">
</span>
Output
* Line 1: The integer with the largest prime factor. If there are more than one, output the one that appears earliest in the input file.
 
<span style="font-size:14px;">
</span>
Sample Input
4 36 38 40 42
 
<span style="font-size:14px;">
</span>
Sample Output
38
 
<span style="font-size:14px;">
</span>
Source
USACO 2005 October Bronze 
<span style="font-size:14px;">一道水题,用筛选素数或者直接就出来了,但就是因为一个小细节,浪费了一下午。</span>
<span style="font-size:14px;">代码如下:</span>
<span style="font-size:14px;">#include<stdio.h>
int prime(int n)
{
	int i;
	for(i=2;i<n-1;i++)
	if(n%i==0)
		return 0;
	return 1;
}
int main()
{
	int i,j,n,m,max,max1;
	while(~scanf("%d",&n))
	{
		max=0;
		for(i=0;i<n;i++)
		{
			scanf("%d",&m);
			for(j=m;j>0;j--)
			{
				if(m%j==0&&prime(j))//代码都不变将这两项次序发生变化,就会超时 诶,做的时候没注意啊
				{
					if(j>=max)
					max=j,max1=m;
					break;
				}
			}
		}
		printf("%d\n",max1);
	}
	return 0;
}</span>

杭电 2710(水题),布布扣,bubuko.com

杭电 2710(水题)

标签:杭电

原文地址:http://blog.csdn.net/ice_alone/article/details/38495215

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!