码迷,mamicode.com
首页 > 其他好文 > 详细

划分树模板题

时间:2014-08-11 17:57:42      阅读:233      评论:0      收藏:0      [点我收藏+]

标签:划分树

原题http://poj.org/problem?id=2104

K-th Number
Time Limit: 20000MS   Memory Limit: 65536K
Total Submissions: 37130   Accepted: 11974
Case Time Limit: 2000MS

Description

You are working for Macrohard company in data structures department. After failing your previous task about key insertion you were asked to write a new data structure that would be able to return quickly k-th order statistics in the array segment. 
That is, given an array a[1...n] of different integer numbers, your program must answer a series of questions Q(i, j, k) in the form: "What would be the k-th number in a[i...j] segment, if this segment was sorted?" 
For example, consider the array a = (1, 5, 2, 6, 3, 7, 4). Let the question be Q(2, 5, 3). The segment a[2...5] is (5, 2, 6, 3). If we sort this segment, we get (2, 3, 5, 6), the third number is 5, and therefore the answer to the question is 5.

Input

The first line of the input file contains n --- the size of the array, and m --- the number of questions to answer (1 <= n <= 100 000, 1 <= m <= 5 000). 
The second line contains n different integer numbers not exceeding 109 by their absolute values --- the array for which the answers should be given. 
The following m lines contain question descriptions, each description consists of three numbers: i, j, and k (1 <= i <= j <= n, 1 <= k <= j - i + 1) and represents the question Q(i, j, k).

Output

For each question output the answer to it --- the k-th number in sorted a[i...j] segment.

Sample Input

7 3
1 5 2 6 3 7 4
2 5 3
4 4 1
1 7 3

Sample Output

5
6
3
#include <stdio.h>
#include <stdlib.h>
#include <malloc.h>
#include <limits.h>
#include <ctype.h>
#include <algorithm>
#include <iostream>
#include <math.h>
#include <string.h>
#include <string>
#include <stack>
#include <queue>
#include <deque>
#include <vector>
#include <set>
#include <map>
using namespace std;
#define mid ((l+r)>>1)
#define maxn 100010
int t[20][maxn],sum[20][maxn];
int a[maxn],as[maxn];
//以下为查找区间第k小划分树
void build(int p,int l,int r)
{
    int lm=0,i,ls=l,rs=mid+1;//lm表示应被放入左子树且与中位数相等的数有多少个,ls为左子树的起始位置,rs为右子树的起始位置
    for(i=mid; i>=l; i--) //求lm
    {
        if(as[i]==as[mid])
            lm++;
        else
            break;
    }
    for(i=l; i<=r; i++)
    {
        if(i==l)//这里要特殊讨论
            sum[p][i]=0;
        else
            sum[p][i]=sum[p][i-1];
        if(t[p][i]==as[mid])//若与中位数相等则判断是否应该被放入左子树
        {
            if(lm)
            {
                lm--;
                sum[p][i]++;
                t[p+1][ls++]=t[p][i];
            }
            else
                t[p+1][rs++]=t[p][i];
        }
        else if(t[p][i]<as[mid])//查找区间第K大即为>
        {
            sum[p][i]++;
            t[p+1][ls++]=t[p][i];
        }
        else
            t[p+1][rs++]=t[p][i];
    }
    if(l==r)
        return;
    build(p+1,l,mid);
    build(p+1,mid+1,r);
}
int query(int p,int l,int r,int ql,int qr,int k)
{
    int s,ss;//s表示l到ql-1的区间内放入左子树的个数,ss表示区间[ql,qr]被放入左子树的个数
    if(l==r)//找到所求的数
        return t[p][l];
    if(ql==l)
        s=0,ss=sum[p][qr];
    else
        s=sum[p][ql-1],ss=sum[p][qr]-s;
    if(k<=ss)//要找的数在左子树中
        return query(p+1,l,mid,l+s,l+sum[p][qr]-1,k);
    else//要找的数在右子树中
        return query(p+1,mid+1,r,mid+1-l+ql-s,mid+1-l+qr-sum[p][qr],k-ss);
}
int main(){
    int i,n,m,j;
    scanf("%d%d",&n,&m);
    for(i=1;i<=n;i++){
        scanf("%d",&as[i]);
        t[0][i] = as[i];
    }
    sort(as+1,as+1+n);
    build(0,1,n);
    while(m--){
        int l,r,k;;
        scanf("%d%d%d",&l,&r,&k);
        int ans = query(0,1,n,l,r,k);
        printf("%d\n",ans);
    }

    return 0;
}


 

划分树模板题,布布扣,bubuko.com

划分树模板题

标签:划分树

原文地址:http://blog.csdn.net/zcr_7/article/details/38494349

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!