码迷,mamicode.com
首页 > 其他好文 > 详细

POJ2184Cow Exhibition(二维费用背包)

时间:2014-08-11 17:58:32      阅读:299      评论:0      收藏:0      [点我收藏+]

标签:acm   二维费用背包   

Cow Exhibition
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 9067   Accepted: 3441

Description

"Fat and docile, big and dumb, they look so stupid, they aren‘t much
fun..."
- Cows with Guns by Dana Lyons

The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be put on by the cows. She has given each of the N (1 <= N <= 100) cows a thorough interview and determined two values for each cow: the smartness Si (-1000 <= Si <= 1000) of the cow and the funness Fi (-1000 <= Fi <= 1000) of the cow.

Bessie must choose which cows she wants to bring to her exhibition. She believes that the total smartness TS of the group is the sum of the Si‘s and, likewise, the total funness TF of the group is the sum of the Fi‘s. Bessie wants to maximize the sum of TS and TF, but she also wants both of these values to be non-negative (since she must also show that the cows are well-rounded; a negative TS or TF would ruin this). Help Bessie maximize the sum of TS and TF without letting either of these values become negative.

Input

* Line 1: A single integer N, the number of cows

* Lines 2..N+1: Two space-separated integers Si and Fi, respectively the smartness and funness for each cow.

Output

* Line 1: One integer: the optimal sum of TS and TF such that both TS and TF are non-negative. If no subset of the cows has non-negative TS and non- negative TF, print 0.

Sample Input

5
-5 7
8 -6
6 -3
2 1
-8 -5

Sample Output

8

Hint

OUTPUT DETAILS:

Bessie chooses cows 1, 3, and 4, giving values of TS = -5+6+2 = 3 and TF
= 7-3+1 = 5, so 3+5 = 8. Note that adding cow 2 would improve the value
of TS+TF to 10, but the new value of TF would be negative, so it is not
allowed.

Source

背包九讲的:二维费用问题

问题
二维费用的背包问题是指:对于每件物品,具有两种不同的费用;选择这件物品必须同时付出这两种代价;对于每种代价都有一个可付出的最大值(背包容量)。问怎样选择物品可以得到最大的价值。设这两种代价分别为代价1和代价2,第i件物品所需的两种代价分别为a[i]b[i]。两种代价可付出的最大值(两种背包容量)分别为VU。物品的价值为w[i]


算法

费用加了一维,只需状态也加一维即可。设f[i][v][u]表示前i件物品付出两种代价分别为vu时可获得的最大价值。状态转移方程就是:f [i][v][u]=max{f[i-1][v][u],f[i-1][v-a[i]][u-b[i]]+w[i]}。如前述方法,可以只使用二维的数组:当每件物品只可以取一次时变量vu采用顺序的循环,当物品有如完全背包问题时采用逆序的循环。当物品有如多重背包问题时拆分物品。


物品总个数的限制

有时,二维费用的条件是以这样一种隐含的方式给出的:最多只能取M件物品。这事实上相当于每件物品多了一种件数的费用,每个物品的件数费用均为1,可以付出的最大件数费用为M。换句话说,设f[v][m]表示付出费用v、最多选m件时可得到的最大价值,则根据物品的类型(01、完全、多重)用不同的方法循环更新,最后在f[0..V][0..M]范围内寻找答案。


另外,如果要求恰取M件物品,则在f[0..V][M]范围内寻找答案。


小结

事实上,当发现由熟悉的动态规划题目变形得来的题目时,在原来的状态中加一纬以满足新的限制是一种比较通用的方法。希望你能从本讲中初步体会到这种方法。
 

 

#include<iostream>
#include<cstdio>
#include<cmath>
#include<queue>
#include<algorithm>
#include<cstring>
using namespace std;
const int MX=1<<30;
int dp[210000];
int main()
{

    int n;
    while( scanf("%d",&n)!=EOF)
    {
        int c[110],w[110],i,j;
        for(i=0;i<n;i++)
           {
               scanf("%d%d",c+i,w+i);
           }
        //memset(dp,-MX,sizeof dp);
        for(i=0;i<=200000;i++)
            dp[i]=-MX;
        dp[100000]=0;
        for(i=0;i<n;i++)
        {
            if(c[i]<0&&w[i]<0)continue;
            if(c[i]>0)
            {
                for(j=200000;j>=c[i];j--)
                {
                    if(dp[j]<dp[j-c[i]]+w[i]&&dp[j-c[i]]>-MX)
                    {
                        dp[j]=dp[j-c[i]]+w[i];
                    }
                }
            }else{
                for(j=0;j<=200000+c[i];j++)
                {
                    if(dp[j]<dp[j-c[i]]+w[i]&&dp[j-c[i]]>-MX)
                    {
                        dp[j]=dp[j-c[i]]+w[i];
                    }
                }
            }
        }
        int s=0;
        for(i=100000;i<=200000;i++)
        {
            if(s<i-100000+dp[i]&&dp[i]>=0)
                s=i-100000+dp[i];
        }
        printf("%d\n",s);
    }
    return 0;
}


 

POJ2184Cow Exhibition(二维费用背包),布布扣,bubuko.com

POJ2184Cow Exhibition(二维费用背包)

标签:acm   二维费用背包   

原文地址:http://blog.csdn.net/fljssj/article/details/38494257

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!