码迷,mamicode.com
首页 > 其他好文 > 详细

训练赛(1---5)D

时间:2014-08-11 20:30:42      阅读:230      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   color   io   strong   for   ar   

一、题目

Description

Sometimes you have to try fighting even though you know that your enemy is very powerful than you. Your hero with initial health H is about to fight against a venomous enemy who has a poisonous value of P. The enemy‘s poison deals i*P damage at it‘s ith attacking chance(i>=1). The hero dies when his health becomes <=0. After enemy‘s attack, if the hero survives, he heals himself with a health of A by using his skills. Then the enemy gets the chance again and the cycle continues till the hero dies. Find the survival time of the hero. You can safely assume that the hero is mortal.

Example Scenario:

Initial Health(H) = 10, Poison (P) = 2, Heal value(A) = 1

At time 1, enemy does 1*2 damage reducing the hero‘s health to 8

At time 2, hero heals himself by 1 increasing his health to 9

At time 3, enemy does 2*2 damage reducing the hero‘s health to 5

At time 4, hero heals himself by 1 increasing his health to 6

At time 5, enemy does 3*2 damage and kill the hero.

The hero survived 5 units of time.

Input:

The first line consists of an integer t, the number of test cases. For each test case there is a line with 3 integers H, P and A.

Output:

For each test case, find the survival time of the hero.

Input Constraints:

1<=t<=10^6

1<=H<=10^6

1<=P<=10^6

0<=A<P

Sample Input:

3

3 7 2

81 4 1

87 8 4

Sample Output:

1

13

9

 

二、程序代码

#include <cstdio>
typedef long long LL;
int H,P,A;
bool judge(int n)
{
    LL ans = (LL)(n+1)*n/2*P-(LL)(n-1)*A-H;
    if(ans >= 0) return 1;
    return 0;
}

int main()
{
    int kase;
    scanf("%d",&kase);
    while(kase--)
    {
        scanf("%d%d%d",&H,&P,&A);
        int l = 1,r = 1000000,ans = l;
        while(l <= r)
        {
            int mid = (l+r)>>1;
            if(judge(mid))  r = mid-1,ans = mid;
            else    l = mid+1;
        }
        printf("%d\n",ans*2-1);
    }
    return 0;
}

 

三、心得体会

  做这道题时一直把它当做暴力的题来做,一直超时。

  用二分就好啦~~

  直接二分英雄死亡的时间,然后计算判断即可~~~

训练赛(1---5)D,布布扣,bubuko.com

训练赛(1---5)D

标签:des   style   blog   color   io   strong   for   ar   

原文地址:http://www.cnblogs.com/fightfor/p/3905183.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!