码迷,mamicode.com
首页 > 其他好文 > 详细

HDU2988 Dark roads 【最小生成树Kruskal】

时间:2014-08-11 21:26:42      阅读:208      评论:0      收藏:0      [点我收藏+]

标签:hdu2988

Dark roads

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 583    Accepted Submission(s): 253


Problem Description
Economic times these days are tough, even in Byteland. To reduce the operating costs, the government of Byteland has decided to optimize the road lighting. Till now every road was illuminated all night long, which costs 1 Bytelandian Dollar per meter and day. To save money, they decided to no longer illuminate every road, but to switch off the road lighting of some streets. To make sure that the inhabitants of Byteland still feel safe, they want to optimize the lighting in such a way, that after darkening some streets at night, there will still be at least one illuminated path from every junction in Byteland to every other junction.

What is the maximum daily amount of money the government of Byteland can save, without making their inhabitants feel unsafe?

 

Input
The input file contains several test cases. Each test case starts with two numbers m and n, the number of junctions in Byteland and the number of roads in Byteland, respectively. Input is terminated by m=n=0. Otherwise, 1 ≤ m ≤ 200000 and m-1 ≤ n ≤ 200000. Then follow n integer triples x, y, z specifying that there will be a bidirectional road between x and y with length z meters (0 ≤ x, y < m and x ≠ y). The graph specified by each test case is connected. The total length of all roads in each test case is less than 231.
 

Output
For each test case print one line containing the maximum daily amount the government can save.
 

Sample Input
7 11 0 1 7 0 3 5 1 2 8 1 3 9 1 4 7 2 4 5 3 4 15 3 5 6 4 5 8 4 6 9 5 6 11 0 0
 

Sample Output
51
 

Source

给定n条边求最小生成树。

#include <stdio.h>
#include <string.h>
#include <algorithm>
#define maxn 200002
using std::sort;

struct Node {
	int u, v, cost;
} E[maxn];
int pre[maxn];

void addEdge(int a, int b, int c, int i)
{
	E[i].u = a; E[i].v = b; E[i].cost = c;
}

bool cmp(Node a, Node b) {
	return a.cost < b.cost;
}

int ufind(int k){
	int a = k, b;
	while(pre[k] != -1) k = pre[k];
	while(a != k) {
		b = pre[a];
		pre[a] = k;
		a = b;
	}
	return k;
}

int Kruskal(int n, int m)
{
	memset(pre, -1, sizeof(pre));
	int u, v, i, count = n, len = 0;
	for(i = 0; i < m; ++i) {
		u = ufind(E[i].u);
		v = ufind(E[i].v);
		if(u != v) {
			len += E[i].cost;
			pre[v] = u;
			if(--count == 1) break;
		}
	}
	return len;
}

int main()
{
	int n, m, total, i, a, b, c;
	while(scanf("%d%d", &n, &m), n || m) {
		for(i = total = 0; i < m; ++i) {
			scanf("%d%d%d", &a, &b, &c);
			addEdge(a, b, c, i);
			total += c;
		}
		sort(E, E + m, cmp);
		printf("%d\n", total - Kruskal(n, m));
	}
	return 0;
}


HDU2988 Dark roads 【最小生成树Kruskal】,布布扣,bubuko.com

HDU2988 Dark roads 【最小生成树Kruskal】

标签:hdu2988

原文地址:http://blog.csdn.net/chang_mu/article/details/38497743

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!