码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 5533 Dancing Stars on Me 计算几何瞎暴力

时间:2016-09-15 21:36:48      阅读:281      评论:0      收藏:0      [点我收藏+]

标签:

Dancing Stars on Me

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 1184    Accepted Submission(s): 651


Problem Description
The sky was brushed clean by the wind and the stars were cold in a black sky. What a wonderful night. You observed that, sometimes the stars can form a regular polygon in the sky if we connect them properly. You want to record these moments by your smart camera. Of course, you cannot stay awake all night for capturing. So you decide to write a program running on the smart camera to check whether the stars can form a regular polygon and capture these moments automatically.

Formally, a regular polygon is a convex polygon whose angles are all equal and all its sides have the same length. The area of a regular polygon must be nonzero. We say the stars can form a regular polygon if they are exactly the vertices of some regular polygon. To simplify the problem, we project the sky to a two-dimensional plane here, and you just need to check whether the stars can form a regular polygon in this plane.
 

 

Input
The first line contains a integer T indicating the total number of test cases. Each test case begins with an integer n, denoting the number of stars in the sky. Following n lines, each contains 2 integers xi,yi, describe the coordinates of n stars.

1T300
3n100
10000xi,yi10000
All coordinates are distinct.
 

 

Output
For each test case, please output "`YES`" if the stars can form a regular polygon. Otherwise, output "`NO`" (both without quotes).
 

 

Sample Input
3 3 0 0 1 1 1 0 4 0 0 0 1 1 0 1 1 5 0 0 0 1 0 2 2 2 2 0
 

 

Sample Output
NO YES NO
 

 

Source
 

 

Recommend
hujie   |   We have carefully selected several similar problems for you:  5877 5876 5875 5874 5873 
 
给一些点 问组成的图形是不是正的
瞎暴力一下就可以了 (其实遇到这种题基本也只会暴力
把所有点互相的距离都求出来
然后排下序 看最小的点和第n小的点是否相等就可以
 
#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <queue>
#include <vector>
#include <iomanip>
#include <math.h>
#include <map>
using namespace std;
#define FIN     freopen("input.txt","r",stdin);
#define FOUT    freopen("output.txt","w",stdout);
#define INF     0x3f3f3f3f
#define INFLL   0x3f3f3f3f3f3f3f
#define lson    l,m,rt<<1
#define rson    m+1,r,rt<<1|1
typedef long long LL;
typedef pair<int,int> PII;

const int MAXN = 1e2 + 5;

int T, n;
int a[MAXN], b[MAXN];
double dis[MAXN * MAXN];

int main()
{
    //FIN
    scanf("%d", &T);
    while(T--) {
        scanf("%d", &n);
        for(int i = 1; i <= n; i++) {
            scanf("%d%d", &a[i], &b[i]);
        }

        int cas = 0;

        for(int i = 1; i <= n - 1; i++) {
            for(int j = i + 1; j <= n; j++) {
                dis[++cas] = (double) sqrt((a[j] - a[i])*(a[j] - a[i]) + (b[j] - b[i])*(b[j] - b[i]));
            }
        }
        sort(dis + 1, dis + cas + 1);
//        for(int i = 1; i <= cas; i++) {
//            cout << dis[i] << endl;
//        }
//        cout << "cas=" << cas << endl;
        if(dis[1] == dis[n]) printf("YES\n");
        else printf("NO\n");
    }

    return 0;
}

  

HDU 5533 Dancing Stars on Me 计算几何瞎暴力

标签:

原文地址:http://www.cnblogs.com/Hyouka/p/5875299.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!