码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 1068--Parencodings--括号逆匹配(模拟)

时间:2014-08-11 21:33:53      阅读:285      评论:0      收藏:0      [点我收藏+]

标签:des   style   color   os   io   strong   for   ar   

Parencodings
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 19655   Accepted: 11870

Description

Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways: 
q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence). 
q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence). 

Following is an example of the above encodings: 
	S		(((()()())))

	P-sequence	    4 5 6666

	W-sequence	    1 1 1456


Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string. 

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence. 

Output

The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.

Sample Input

2
6
4 5 6 6 6 6
9 
4 6 6 6 6 8 9 9 9

Sample Output

1 1 1 4 5 6
1 1 2 4 5 1 1 3 9

Source


题意搞了就好几天。。sad 回来补题

题目中给了两个序列 p 和 w 和一个串s(s是已经匹配好的括号)其中p序列中的第i个数代表第i个右括号前面的左括号的个数(好蛋疼) w序列中第i个数代表第i个右括号和与之匹配的左括号这中间有多少对匹配的括号(包括i) 很简单,根据给定p序列把s串模拟出来,然后从左边开始遍历s,遇到右括号就向前逆向匹配,就是找到与这个右括号匹配的左括号,可以设两个变量l,r 初始化为0,从遇到的这个右括号的位置开始遇到左括号l++,遇到右括号r++,当l==r时 l的值就是匹配的括号的对数。

#include <cstdio>
#include <iostream>
#include <cstring>
#include <cstdlib>
#include <cctype>
#include <algorithm>
#include <vector>
using namespace std;
int a[1000100],ans[1000100];
char s[1000010];
int main()
{

	int i,j,n,t;
	cin>>t;getchar();
	while(t--)
	{
	  int p=0;
	  cin>>n;a[0]=0;
	  for(i=1;i<=n;i++)
		cin>>a[i];
	  for(i=1;i<=n;i++)
	  {
	  	for(j=0;j<a[i]-a[i-1];j++)
			s[p++]='(';
		s[p++]=')';
	  }
	  s[p]='\0';
	  //cout<<s<<endl;
	  int q=0;
	  for(i=0;i<p;i++)
	  {
	  	if(s[i]==')')
		{
			int l=0,r=0;
			for(j=i;j>=0;j--)
			{
				if(s[j]=='(')l++;
				if(s[j]==')')r++;
				if(l==r) break;
			}
			ans[q++]=r;
		}
	  }
	  for(i=0;i<q;i++)
		if(i!=q-1)
		cout<<ans[i]<<" ";
	    else
		cout<<ans[i]<<endl;
	}
	return 0;
}


POJ 1068--Parencodings--括号逆匹配(模拟),布布扣,bubuko.com

POJ 1068--Parencodings--括号逆匹配(模拟)

标签:des   style   color   os   io   strong   for   ar   

原文地址:http://blog.csdn.net/qq_16255321/article/details/38496853

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!