码迷,mamicode.com
首页 > 其他好文 > 详细

HDU-3863 No Gambling

时间:2014-08-12 10:13:04      阅读:203      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   java   os   io   

             http://acm.hdu.edu.cn/showproblem.php?pid=3863

                    No Gambling

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65568/32768 K (Java/Others)
Total Submission(s): 1280    Accepted Submission(s): 886


Problem Description
One day, Flyvan introduced a new game to his two friends, Oregon Maple and Grape Skin. The game is quite simple. Given an N-sized grids, like the figure A shown below (as N = 4). The blue points are the places the first player can choose, and the red points are the places the second player can choose.
bubuko.com,布布扣

In the game, the two players take turns to choose two points to get connected by a stick. The two chosen points’ distance should be exactly one-unit length. The first player’s goal is to create a ‘bridge’ that connects a most left point and a most right point. The second player’s goal is to create a ‘bridge’ that connects a most top point and a most bottom point. Figure B shows a possible result (the first player won). In addition, the stick shouldn’t get crossed.
Now Flyvan will give the number N, and his two friends will play the game. Both of the two players will choose the best strategy. You can bet on one player, and if he wins the game, you’ll get twice money you bet~
Since you are a talented programmer, you surely won’t just do gambling. Please write a program to find out the player who you should bet on. As Oregon Maple is elder, he will always play first.
 

 

Input
Each line of the input is an integer N (2 <= N <= 270000), which indicated the number Flyvan chose. The end-of-file is denoted by a single line containing the number -1.
 

 

Output
If you think the first player will win, please output “I bet on Oregon Maple~”, else please output “I bet on Grape Skin~”.
 

 

Sample Input
2
-1
 

 

Sample Output
I bet on Oregon Maple~
这题,我就认为第一个赢,就这么写就过了,但我不相信于是看了别人的解题报告,好复杂。。。。。是我太水了。
#include<iostream>
#include<cstdio>
using namespace std;
int main()
{
    int n;
  while(~scanf("%d",&n))
  {
      if(n==-1)
         break;
      else
         printf("I bet on Oregon Maple~\n");
  }
  return 0;
}

 

HDU-3863 No Gambling,布布扣,bubuko.com

HDU-3863 No Gambling

标签:des   style   blog   http   color   java   os   io   

原文地址:http://www.cnblogs.com/cancangood/p/3906508.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!