码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1019 Least Common Multiple

时间:2016-09-25 21:55:14      阅读:141      评论:0      收藏:0      [点我收藏+]

标签:

Least Common Multiple

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 46786    Accepted Submission(s): 17601


Problem Description
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

 

 

Input
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.
 

 

Output
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.
 

 

Sample Input
2
3 5 7 15
6 4 10296 936 1287 792 1
 
Sample Output
105
10296
 
题解:最小公倍数,先求最大公约数。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int gcd(int n, int m){
    //大小交换
     if(m>n){
         int temp = n;
         n =m;
         m = temp;
     }
        int r =1;
        while(m!=0){
         r = n%m;
         n = m;
         m = r;
        }
    return n;
}
int main()
{
    int t, x;
    cin>>t;
    while(t--){
      int n,b, sum=1;
      cin>>n;
      for(int i=0; i<n; i++){
          cin>>x;
         b = gcd(sum, x);
         sum = sum/b*x;
        }
        printf("%d\n",sum);
    }
 return 0;
}

  

 
 
 

HDU 1019 Least Common Multiple

标签:

原文地址:http://www.cnblogs.com/lzeffort/p/5906862.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!