码迷,mamicode.com
首页 > 其他好文 > 详细

HDU1217 Arbitrage 【SPFA】

时间:2014-08-12 17:14:04      阅读:228      评论:0      收藏:0      [点我收藏+]

标签:hdu1217

Arbitrage

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4460    Accepted Submission(s): 2032


Problem Description
Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent.

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.
 

Input
The input file will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible.
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.
 

Output
For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".
 

Sample Input
3 USDollar BritishPound FrenchFranc 3 USDollar 0.5 BritishPound BritishPound 10.0 FrenchFranc FrenchFranc 0.21 USDollar 3 USDollar BritishPound FrenchFranc 6 USDollar 0.5 BritishPound USDollar 4.9 FrenchFranc BritishPound 10.0 FrenchFranc BritishPound 1.99 USDollar FrenchFranc 0.09 BritishPound FrenchFranc 0.19 USDollar 0
 

Sample Output
Case 1: Yes Case 2: No
 

Source
题意:给定各个货币间的汇率,问存不存在套现环。

题解:这题类似于找负环,所以用SPFA。

#include <stdio.h>
#include <string.h>
#include <string>
#include <queue>
#include <map>
#define maxn 36
using namespace std;

double rate[maxn][maxn], dist[maxn];
bool vis[maxn];

void SPFA(int s, int n)
{
	int i, j, now, tmp;
	for(i = 1; i <= n; ++i){
		vis[i] = 0; dist[i] = 0.0;
	}
	queue<int> Q;
	dist[s] = 1.0; vis[s] = 1;
	Q.push(s);
	while(!Q.empty()){
		now = Q.front(); Q.pop();
		vis[now] = 0;
		for(i = 1; i <= n; ++i){
			if(dist[i] < dist[now] * rate[now][i]){
				if(!vis[i]) Q.push(i); vis[i] = 1;
				dist[i] = dist[now] * rate[now][i];
				if(dist[s] > 1) return;
			}
		}
	}
}

int main()
{
	int n, i, m, cas = 1;
	char buf[50], buf2[50];
	double val;
	map<string, int> mp;
	while(scanf("%d", &n), n){
		mp.clear();
		memset(rate, 0, sizeof(rate));
		for(i = 1; i <= n; ++i){
			scanf("%s", buf);
			mp[buf] = i;
		}
		scanf("%d", &m);
		for(i = 0; i < m; ++i){
			scanf("%s%lf%s", buf, &val, buf2);
			rate[mp[buf]][mp[buf2]] = val;
		}
		SPFA(1, n);
		printf("Case %d: %s\n", cas++, dist[1] > 1 ? "Yes" : "No");
	}
	return 0;
}


HDU1217 Arbitrage 【SPFA】,布布扣,bubuko.com

HDU1217 Arbitrage 【SPFA】

标签:hdu1217

原文地址:http://blog.csdn.net/chang_mu/article/details/38516843

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!