码迷,mamicode.com
首页 > 其他好文 > 详细

POJ1745动态规划

时间:2016-09-26 17:42:46      阅读:148      评论:0      收藏:0      [点我收藏+]

标签:

Divisibility
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 11622   Accepted: 4178

Description

Consider an arbitrary sequence of integers. One can place + or - operators between integers in the sequence, thus deriving different arithmetical expressions that evaluate to different values. Let us, for example, take the sequence: 17, 5, -21, 15. There are eight possible expressions: 17 + 5 + -21 + 15 = 16 
17 + 5 + -21 - 15 = -14 
17 + 5 - -21 + 15 = 58 
17 + 5 - -21 - 15 = 28 
17 - 5 + -21 + 15 = 6 
17 - 5 + -21 - 15 = -24 
17 - 5 - -21 + 15 = 48 
17 - 5 - -21 - 15 = 18 
We call the sequence of integers divisible by K if + or - operators can be placed between integers in the sequence in such way that resulting value is divisible by K. In the above example, the sequence is divisible by 7 (17+5+-21-15=-14) but is not divisible by 5. 

You are to write a program that will determine divisibility of sequence of integers. 

Input

The first line of the input file contains two integers, N and K (1 <= N <= 10000, 2 <= K <= 100) separated by a space. 
The second line contains a sequence of N integers separated by spaces. Each integer is not greater than 10000 by it‘s absolute value. 

Output

Write to the output file the word "Divisible" if given sequence of integers is divisible by K or "Not divisible" if it‘s not.

Sample Input

4 7
17 5 -21 15

Sample Output

Divisible

思路:定义bool数组dp[10005][105],dp[i][j]表示前i+1个数所形成的和模上k是否为j.状态转移方程:if(dp[i-1][j]){ dp[i][mod(j+a[i],k)]=true;dp[i][mod(j-a[i],k)]=true;}
#include <cstdio>
#include <cstring>
using namespace std;
const int MAXN=10005;
bool dp[MAXN][105];
int a[MAXN];
int n,k;
int mod(int x,int m)
{
    x%=m;
    if(x<0) x+=m;
    return x;
}
int main()
{

    while(scanf("%d%d",&n,&k)!=EOF)
    {
        memset(dp,false,sizeof(dp));
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
        }
        dp[0][mod(a[0],k)]=true;
        for(int i=1;i<n;i++)
        {
            for(int j=0;j<k;j++)
            {
                if(dp[i-1][j])
                {
                    dp[i][mod(j+a[i],k)]=true;
                    dp[i][mod(j-a[i],k)]=true;
                }
            }
        }

        if(dp[n-1][0])
        {
            printf("Divisible\n");
        }
        else
        {
            printf("Not divisible\n");
        }
    }
    return 0;
}

 

POJ1745动态规划

标签:

原文地址:http://www.cnblogs.com/program-ccc/p/5909780.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!