码迷,mamicode.com
首页 > 其他好文 > 详细

poj 1936 All in All

时间:2016-09-27 10:16:57      阅读:106      评论:0      收藏:0      [点我收藏+]

标签:

Description

You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string. 

Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s. 

Input

The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace.The length of s and t will no more than 100000.

Output

For each test case output "Yes", if s is a subsequence of t,otherwise output "No".

Sample Input

sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter

Sample Output

Yes
No
Yes
No

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;

char s[100005],t[100005];
int data[100005];

int main()
{
    int flag,k,m;
    while(scanf("%s%s",s,t)!=-1)
    {
        int lens,lent;
        lens=strlen(s);
        lent=strlen(t);
        k=0;
        flag=0;
        for(int i=0;i<lent;i++)
        {
            if(t[i]==s[0])
            data[k++]=i;
        }
        for(int i=0;i<k;i++)
        {
            m=0;
            for(int j=data[i];j<lent;j++)
            {
                if(t[j]==s[m])
                m++;
                if(m==lens)
                {
                    flag=1;break;
                }
            }
            if(flag) break;
        }
        if(flag) cout<<"Yes"<<endl;
        else cout<<"No"<<endl;
    }
    return 0;
}

 

poj 1936 All in All

标签:

原文地址:http://www.cnblogs.com/nefu929831238/p/5911743.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!