码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1247 Hat’s Words

时间:2016-09-29 21:28:58      阅读:126      评论:0      收藏:0      [点我收藏+]

标签:

Hat’s Words

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13752    Accepted Submission(s): 4919


Problem Description
A hat’s word is a word in the dictionary that is the concatenation of exactly two other words in the dictionary.
You are to find all the hat’s words in a dictionary.
 

 

Input
Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will be no more than 50,000 words.
Only one case.
 

 

Output
Your output should contain all the hat’s words, one per line, in alphabetical order.
 

 

Sample Input
a
ahat
hat
hatword
hziee
word
 

 

Sample Output
ahat
hatword
 

 

Author
戴帽子的
 
 
 
解析:字典树。
 
 
 
#include <cstdio>
#include <cstring>

char s[50005][50];

struct Node{
    Node* pt[26];
    bool isEnd;
};

Node* root;
Node memory[100000];
int allo;

void trie_init()
{
    memset(memory, 0, sizeof(memory));
    allo = 0;
    root = &memory[allo++];
}

void trie_insert(char str[])
{
    Node *p = root;
    for(int i = 0; str[i] != ‘\0‘; ++i){
        int id = str[i]-‘a‘;
        if(p->pt[id] == NULL){
            p->pt[id] = &memory[allo++];
        }
        p = p->pt[id];
    }
    p->isEnd = true;
}

bool trie_find(char str[])
{
    Node *p = root;
    for(int i = 0; str[i] != ‘\0‘; ++i){
        int id = str[i]-‘a‘;
        if(p->pt[id] == NULL){
            return false;
        }
        p = p->pt[id];
    }
    return p->isEnd;
}

void getans(char str[])
{
    Node* p = root;
    for(int i = 0; str[i] != ‘\0‘; ++i){
        int id = str[i]-‘a‘;
        if(p->pt[id] == NULL){
            return;
        }
        else{
            if(p->pt[id]->isEnd && str[i+1] != ‘\0‘){
                bool ok = trie_find(str+i+1);
                if(ok){
                    printf("%s\n", str);
                    return;
                }
            }
        }
        p = p->pt[id];
    }
}

void solve(int n)
{
    trie_init();
    for(int i = 0; i < n; ++i){
        trie_insert(s[i]);
    }
    for(int i = 0; i < n; ++i){
        getans(s[i]);
    }
}

int main()
{
    int n = 0;
    while(gets(s[n])){
        ++n;
    }
    solve(n);
    return 0;
}

  

HDU 1247 Hat’s Words

标签:

原文地址:http://www.cnblogs.com/inmoonlight/p/5921071.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!