码迷,mamicode.com
首页 > 其他好文 > 详细

Median Weight Bead_floyd

时间:2016-09-30 23:32:12      阅读:221      评论:0      收藏:0      [点我收藏+]

标签:

Description

There are N beads which of the same shape and size, but with different weights. N is an odd number and the beads are labeled as 1, 2, ..., N. Your task is to find the bead whose weight is median (the ((N+1)/2)th among all beads). The following comparison has been performed on some pairs of beads: 
A scale is given to compare the weights of beads. We can determine which one is heavier than the other between two beads. As the result, we now know that some beads are heavier than others. We are going to remove some beads which cannot have the medium weight. 

For example, the following results show which bead is heavier after M comparisons where M=4 and N=5. 
1.	Bead 2 is heavier than Bead 1.

2. Bead 4 is heavier than Bead 3.
3. Bead 5 is heavier than Bead 1.
4. Bead 4 is heavier than Bead 2.

From the above results, though we cannot determine exactly which is the median bead, we know that Bead 1 and Bead 4 can never have the median weight: Beads 2, 4, 5 are heavier than Bead 1, and Beads 1, 2, 3 are lighter than Bead 4. Therefore, we can remove these two beads. 

Write a program to count the number of beads which cannot have the median weight. 

Input

The first line of the input file contains a single integer t (1 <= t <= 11), the number of test cases, followed by the input data for each test case. The input for each test case will be as follows: 
The first line of input data contains an integer N (1 <= N <= 99) denoting the number of beads, and M denoting the number of pairs of beads compared. In each of the next M lines, two numbers are given where the first bead is heavier than the second bead. 

Output

There should be one line per test case. Print the number of beads which can never have the medium weight.

Sample Input

1
5 4
2 1
4 3
5 1
4 2

Sample Output

2

 

 

【题意】给出t个例子,有n个形状相同的bead,给出m个他们之间的轻重情况,找出不可能是中间质量的bead的数量

【思路】将轻重情况看成是一个有向图,i重于j就说明i到j有一条边,若i能到超过n/2个点或者i能被超过n/2个点到达,就说明i不是中间质量的bead

 

#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
const int inf=0x3f3f3f3f;
const int N=105;
int n,m;
int mp[N][N];
void floyd()
{
    for(int k=1;k<=n;k++)
    {
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                if(mp[i][k]==1&&mp[k][j]==1)
                    mp[i][j]=1;
                if(mp[i][k]==-1&&mp[k][j]==-1)
                    mp[i][j]=-1;
            }
        }
    }

}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
       memset(mp,0,sizeof(mp));
        scanf("%d%d",&n,&m);
        for(int i=1;i<=m;i++)
        {
            int a,b;
            scanf("%d%d",&a,&b);
            mp[a][b]=1;
            mp[b][a]=-1;
        }
        floyd();
        int ans=0;
        for(int i=1;i<=n;i++)
        {
            int l=0,r=0;
            for(int j=1;j<=n;j++)
            {
                if(mp[i][j]==1)
                    r++;
                else if(mp[i][j]==-1)
                    l++;
            }
            if(r>n/2||l>n/2)
                ans++;
        }
        printf("%d\n",ans);
    }
    return 0;
}

 

Median Weight Bead_floyd

标签:

原文地址:http://www.cnblogs.com/iwantstrong/p/5924901.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!