码迷,mamicode.com
首页 > 其他好文 > 详细

An Easy Task

时间:2016-10-01 12:31:36      阅读:122      评论:0      收藏:0      [点我收藏+]

标签:

描述

Ignatius was born in a leap year, so he want to know when he could hold his birthday party. Can you tell him?

Given a positive integers Y which indicate the start year, and a positive integer N, your task is to tell the Nth leap year from year Y.

Note: if year Y is a leap year, then the 1st leap year is year Y.

输入

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains two positive integers Y and N(1<=N<=10000).

输出

For each test case, you should output the Nth leap year from year Y.

样例输入

3
2005 25
1855 12
2004 10000

样例输出

2108
1904
43236

 

code :

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
bool isLoop(int y){
    if((y%4==0 && y%100!=0) || y%400==0){
      return true;
    }
    return false;
}
int main()
{
    int t, y, n;
    cin>>t;
    while(t--){
       cin>>y>>n;
       while(n){
            if(isLoop(y)){
                n--;
            }
            y++;
         }
         cout<<y-1<<endl;
    }

 return 0;
}

  

An Easy Task

标签:

原文地址:http://www.cnblogs.com/lzeffort/p/5925519.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!