码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 4941 Magical Forest(STL map & 结构体运用)

时间:2014-08-12 22:15:54      阅读:382      评论:0      收藏:0      [点我收藏+]

标签:多校7   优先队列   map   

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4941


Magical Forest

Time Limit: 24000/12000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 220    Accepted Submission(s): 105


Problem Description
There is a forest can be seen as N * M grid. In this forest, there is some magical fruits, These fruits can provide a lot of energy, Each fruit has its location(Xi, Yi) and the energy can be provided Ci.

However, the forest will make the following change sometimes:
1. Two rows of forest exchange.
2. Two columns of forest exchange.
Fortunately, two rows(columns) can exchange only if both of them contain fruits or none of them contain fruits.

Your superior attach importance to these magical fruit, he needs to know this forest information at any time, and you as his best programmer, you need to write a program in order to ask his answers quick every time.
 
Input
The input consists of multiple test cases.

The first line has one integer W. Indicates the case number.(1<=W<=5)

For each case, the first line has three integers N, M, K. Indicates that the forest can be seen as maps N rows, M columns, there are K fruits on the map.(1<=N, M<=2*10^9, 0<=K<=10^5)

The next K lines, each line has three integers X, Y, C, indicates that there is a fruit with C energy in X row, Y column. (0<=X<=N-1, 0<=Y<=M-1, 1<=C<=1000)

The next line has one integer T. (0<=T<=10^5)
The next T lines, each line has three integers Q, A, B.
If Q = 1 indicates that this is a map of the row switching operation, the A row and B row exchange.
If Q = 2 indicates that this is a map of the column switching operation, the A column and B column exchange.
If Q = 3 means that it is time to ask your boss for the map, asked about the situation in (A, B).
(Ensure that all given A, B are legal. )
 
Output
For each case, you should output "Case #C:" first, where C indicates the case number and counts from 1.

In each case, for every time the boss asked, output an integer X, if asked point have fruit, then the output is the energy of the fruit, otherwise the output is 0.
 
Sample Input
1 3 3 2 1 1 1 2 2 2 5 3 1 1 1 1 2 2 1 2 3 1 1 3 2 2
 
Sample Output
Case #1: 1 2 1
Hint
No two fruits at the same location.
 
Author
UESTC
 
Source

题意:

有一个n*m的田地,里边有k棵树,每棵树的位置为(xi,yi),含有能量值ci。之后又q个询问,分三种;

1)1 a b,将a行和b行交换

2)2 a b,将a列和b列交换

3)3 a b,询问(a,b)位置的果树的能量值。


运用map,每次的交换操作只需要交换相应的映射值!


bubuko.com,布布扣
bubuko.com,布布扣
代码如下:(结构体)
#include <cstdio>
#include <map>
#include <algorithm>
using namespace std;
struct node
{
    int x, y;
    friend bool operator < (node a, node b)
    {
        //从大到小排列
        if(a.x != b.x)
            return a.x < b.x;
        else
            return a.y < b.y;
    }
};
node pos;
map<int , int>row,col;//分别记录行和列
map<node, int>p;//优先级队列如果插入的节点是结构体类型,则要在结构体中重载比较操作符函数
int main()
{
    int t;
    int n, m, k;
    int x, y, c;
    int op, xx, yy;
    int cas = 0;
    scanf("%d",&t);
    while(t--)
    {
        int c1 = 0, c2 = 0;
        scanf("%d%d%d",&n,&m,&k);
        for(int i = 0; i < k; i++)
        {
            scanf("%d%d%d",&x, &y, &c);
            if(row[x] == 0)//离散化
                row[x] = ++c1;
            if(col[y] == 0)
                col[y] = ++c2;
            pos.x = row[x];
            pos.y = col[y];
            p[pos] = c;
        }
        int tt, tmp;
        printf("Case #%d:\n",++cas);
        scanf("%d",&tt);
        for(int i = 0; i < tt; i++)
        {
            scanf("%d%d%d",&op,&xx,&yy);
            if(op == 1)
            {
                tmp = row[xx];
                row[xx] = row[yy];
                row[yy] = tmp;
            }
            else if(op == 2)
            {
                tmp = col[xx];
                col[xx] = col[yy];
                col[yy] = tmp;
            }
            else
            {
                pos.x = row[xx];
                pos.y = col[yy];
                printf("%d\n",p[pos]);
            }
        }
    }
    return 0;
}




非结构体:
#include <cstdio>
#include <map>
#include <algorithm>
using namespace std;
map<int , map<int , int> >mm;
map<int , int> row,col;//分别记录行和列
int main()
{
    int t;
    int n, m, k;
    int x, y, c;
    int op, xx, yy;
    int cas = 0;
    scanf("%d",&t);
    while(t--)
    {
        int c1 = 0, c2 = 0;
        scanf("%d%d%d",&n,&m,&k);
        for(int i = 0; i < k; i++)
        {
            scanf("%d%d%d",&x, &y, &c);
            if(row[x] == 0)//离散化
                row[x] = ++c1;
            if(col[y] == 0)
                col[y] = ++c2;
            mm[row[x]][col[y]] = c;
        }
        int tt, tmp;
        printf("Case #%d:\n",++cas);
        scanf("%d",&tt);
        for(int i = 0; i < tt; i++)
        {
            scanf("%d%d%d",&op,&xx,&yy);
            if(op == 1)
            {
                tmp = row[xx];
                row[xx] = row[yy];
                row[yy] = tmp;
            }
            else if(op == 2)
            {
                tmp = col[xx];
                col[xx] = col[yy];
                col[yy] = tmp;
            }
            else
            {
                printf("%d\n",mm[row[xx]][col[yy]]);
            }
        }
    }
    return 0;
}



hdu 4941 Magical Forest(STL map & 结构体运用),布布扣,bubuko.com

hdu 4941 Magical Forest(STL map & 结构体运用)

标签:多校7   优先队列   map   

原文地址:http://blog.csdn.net/u012860063/article/details/38519917

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!