码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 4941 Magical Forest (map容器)

时间:2014-08-12 22:18:44      阅读:475      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   java   os   io   

Magical Forest

Time Limit: 24000/12000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 135    Accepted Submission(s): 69


Problem Description
There is a forest can be seen as N * M grid. In this forest, there is some magical fruits, These fruits can provide a lot of energy, Each fruit has its location(Xi, Yi) and the energy can be provided Ci. 

However, the forest will make the following change sometimes: 
1. Two rows of forest exchange. 
2. Two columns of forest exchange. 
Fortunately, two rows(columns) can exchange only if both of them contain fruits or none of them contain fruits. 

Your superior attach importance to these magical fruit, he needs to know this forest information at any time, and you as his best programmer, you need to write a program in order to ask his answers quick every time.
 

Input
The input consists of multiple test cases. 

The first line has one integer W. Indicates the case number.(1<=W<=5)

For each case, the first line has three integers N, M, K. Indicates that the forest can be seen as maps N rows, M columns, there are K fruits on the map.(1<=N, M<=2*10^9, 0<=K<=10^5)

The next K lines, each line has three integers X, Y, C, indicates that there is a fruit with C energy in X row, Y column. (0<=X<=N-1, 0<=Y<=M-1, 1<=C<=1000)

The next line has one integer T. (0<=T<=10^5)
The next T lines, each line has three integers Q, A, B. 
If Q = 1 indicates that this is a map of the row switching operation, the A row and B row exchange. 
If Q = 2 indicates that this is a map of the column switching operation, the A column and B column exchange. 
If Q = 3 means that it is time to ask your boss for the map, asked about the situation in (A, B). 
(Ensure that all given A, B are legal. )
 

Output
For each case, you should output "Case #C:" first, where C indicates the case number and counts from 1.

In each case, for every time the boss asked, output an integer X, if asked point have fruit, then the output is the energy of the fruit, otherwise the output is 0.
 

Sample Input
1 3 3 2 1 1 1 2 2 2 5 3 1 1 1 1 2 2 1 2 3 1 1 3 2 2
 

Sample Output
Case #1: 1 2 1
Hint
No two fruits at the same location.

bubuko.com,布布扣


#include"stdio.h"
#include"map"
#include"string"
#include"algorithm"
#include"iostream"
using namespace std;
struct node{       //定义结构体
    int x,y;
    bool operator<(const node &a)const
    {                
        if(x==a.x)
            return y<a.y;
        return x<a.x;
    }
};
int main()
{
    map<int,int>x,y;        //两个int类型元素的映射
    map<node ,int>g;        //结构体和int元素的映射
    node e;
    int T,n,m,k,i,j,t,cnt=0;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d%d",&n,&m,&k);
        int x1,y1;
        x1=y1=0;
        while(k--)
        {
            scanf("%d%d%d",&i,&j,&t);
            if(x[i]==0)
                x[i]=++x1;     //把数组原来的i行j列,对应为x1行y1列;
            if(y[j]==0)
                y[j]=++y1;
            e.x=x[i];
            e.y=y[j];
            g[e]=t;         //结构体e对应的int元素为t
        }
        scanf("%d",&k);
        printf("Case #%d:\n",++cnt);
        while(k--)
        {
            int q;
            scanf("%d%d%d",&q,&i,&j);
            if(q==1)
            {
                int t=x[i];
                x[i]=x[j];
                x[j]=t;
            }
            else if(q==2)
            {
                int t=y[i];
                y[i]=y[j];
                y[j]=t;
            }
            else
            {
                e.x=x[i];
                e.y=y[j];
                printf("%d\n",g[e]);
            }
        }
    }
    return 0;
}



hdu 4941 Magical Forest (map容器),布布扣,bubuko.com

hdu 4941 Magical Forest (map容器)

标签:des   style   blog   http   color   java   os   io   

原文地址:http://blog.csdn.net/u011721440/article/details/38519447

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!