码迷,mamicode.com
首页 > 其他好文 > 详细

hdu4941 Magical Forest

时间:2014-08-12 22:19:04      阅读:488      评论:0      收藏:0      [点我收藏+]

标签:2014多校   map   离散化   

Problem Description
There is a forest can be seen as N * M grid. In this forest, there is some magical fruits, These fruits can provide a lot of energy, Each fruit has its location(Xi, Yi) and the energy can be provided Ci. 

However, the forest will make the following change sometimes: 
1. Two rows of forest exchange. 
2. Two columns of forest exchange. 
Fortunately, two rows(columns) can exchange only if both of them contain fruits or none of them contain fruits. 

Your superior attach importance to these magical fruit, he needs to know this forest information at any time, and you as his best programmer, you need to write a program in order to ask his answers quick every time.
Input
The input consists of multiple test cases. 

The first line has one integer W. Indicates the case number.(1<=W<=5)

For each case, the first line has three integers N, M, K. Indicates that the forest can be seen as maps N rows, M columns, there are K fruits on the map.(1<=N, M<=2*10^9, 0<=K<=10^5)

The next K lines, each line has three integers X, Y, C, indicates that there is a fruit with C energy in X row, Y column. (0<=X<=N-1, 0<=Y<=M-1, 1<=C<=1000)

The next line has one integer T. (0<=T<=10^5)
The next T lines, each line has three integers Q, A, B. 
If Q = 1 indicates that this is a map of the row switching operation, the A row and B row exchange. 
If Q = 2 indicates that this is a map of the column switching operation, the A column and B column exchange. 
If Q = 3 means that it is time to ask your boss for the map, asked about the situation in (A, B). 
(Ensure that all given A, B are legal. )
 

Output
For each case, you should output "Case #C:" first, where C indicates the case number and counts from 1.

In each case, for every time the boss asked, output an integer X, if asked point have fruit, then the output is the energy of the fruit, otherwise the output is 0.
 

Sample Input
1 3 3 2 1 1 1 2 2 2 5 3 1 1 1 1 2 2 1 2 3 1 1 3 2 2
 

Sample Output
Case #1: 1 2 1
Hint
No two fruits at the same location.
 


题目中的N, M 太大   所以不能直接记录
用两个map表示,row[i] = j 表示 i行换到了j行,反之同理  col表示列 
另外一个map   maze记录<i, j>这个位置的值
每次查询前先将正确的行列在row,col中映射,输出答案即可

#include <cstdio>
#include <ctime>
#include <cstdlib>
#include <cstring>
#include <queue>
#include <string>
#include <set>
#include <stack>
#include <map>
#include <cmath>
#include <vector>
#include <iostream>
#include <algorithm>
#include <bitset>
#include <fstream>
using namespace std;
//LOOP
#define FF(i, a, b) for(int i = (a); i < (b); ++i)
#define FE(i, a, b) for(int i = (a); i <= (b); ++i)
#define FED(i, b, a) for(int i = (b); i>= (a); --i)
#define REP(i, N) for(int i = 0; i < (N); ++i)
#define CLR(A,value) memset(A,value,sizeof(A))
//OTHER
#define PB push_back
//INPUT
#define RI(n) scanf("%d", &n)
#define RII(n, m) scanf("%d%d", &n, &m)
#define RIII(n, m, k) scanf("%d%d%d", &n, &m, &k)
#define RIV(n, m, k, p) scanf("%d%d%d%d", &n, &m, &k, &p)
#define RV(n, m, k, p, q) scanf("%d%d%d%d%d", &n, &m, &k, &p, &q)
#define RS(s) scanf("%s", s)
//OUTPUT

#define sqr(x) (x) * (x)
typedef long long LL;
typedef unsigned long long ULL;
typedef vector <int> VI;
const double eps = 1e-9;
const int MOD = 1000000007;
const double PI = acos(-1.0);
const int INF = 0x3f3f3f3f;
const int maxn = 100010;

map<int, int>col, row;
map<pair<int, int>, int>maze;
int main()
{
    //freopen("0.txt", "r", stdin);
    int T, n, m, k, a, t;
    RI(T);
    FE(kase, 1, T)
    {
        row.clear(), col.clear(), maze.clear();
        printf("Case #%d:\n", kase);
        RIII(n, m, k);
        int x, y, c, Q;
        REP(i, k)
        {
            RIII(x, y, c);
            maze[make_pair(x, y)] = c;
        }
        int tx, ty;
        RI(Q);
        while (Q--)
        {
            RIII(c, x, y);
            tx = x, ty = y;
            if (c == 2)
            {
                if (col.count(x))   tx = col[x];
                if (col.count(y))   ty = col[y];
                col[x] = ty;
                col[y] = tx;
            }
            else if (c == 1)
            {
                if (row.count(x))   tx = row[x];
                if (row.count(y))   ty = row[y];
                row[x] = ty;
                row[y] = tx;
            }
            else
            {
                if (row.count(x))
                    x = row[x];
                if (col.count(y))
                    y = col[y];
                a = 0;
                if (maze.count(make_pair(x, y)))
                    a = maze[make_pair(x, y)];
                printf("%d\n", a);
            }
        }
    }
    return 0;
}



hdu4941 Magical Forest,布布扣,bubuko.com

hdu4941 Magical Forest

标签:2014多校   map   离散化   

原文地址:http://blog.csdn.net/colin_27/article/details/38519505

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!