码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1001 Sum Problem

时间:2016-10-02 23:50:26      阅读:160      评论:0      收藏:0      [点我收藏+]

标签:

 

Problem Description

Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).

In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.


Input
The input will consist of a series of integers n, one integer per line.


Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.


Sample Input
1

100


Sample Output
1

 

5050

 

Author
DOOM III

题意:输入n,求1到n的和

注意:可以用求和公式,int会溢出,每个答案后要有一个空行

#include <stdio.h>
int main()
{
    int n, sum;
    while (scanf("%d", &n)!=EOF)
    {
        sum=0;
        for (int i=1;i <= n; i++)
           sum += i;
        printf("%d\n\n", sum);
     }
   return 0;
 }

 

HDU 1001 Sum Problem

标签:

原文地址:http://www.cnblogs.com/Noevon/p/5928119.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!