码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1093 A+B for Input-Output Practice (V)

时间:2016-10-03 00:13:59      阅读:138      评论:0      收藏:0      [点我收藏+]

标签:

Problem Description
Your task is to calculate the sum of some integers.
 
Input
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.
 
Output
For each group of input integers you should output their sum in one line, and with one line of output for each line in input.
 
Sample Input
2
4 1 2 3 4
5 1 2 3 4 5
 
Sample Output
10
15
 
题意:输入n,代表n组数据,每组数据包括一个m以及m个数,输出m个数之和
 
#include <stdio.h>
int  main()
{
    int a, sum, n, i, m;
    while (~scanf ("%d", &n)&&n)
    {
        while(n--)
        {
            scanf("%d", &m);
            sum = 0;
            for(i=1;i<=m;i++)
            {
            scanf("%d", &a);
            sum += a;
            }
            printf ("%d\n", sum);
        }
    }
    return 0;
}

 

HDU 1093 A+B for Input-Output Practice (V)

标签:

原文地址:http://www.cnblogs.com/Noevon/p/5928214.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!