码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 2001 计算两点间的距离

时间:2016-10-03 00:21:52      阅读:143      评论:0      收藏:0      [点我收藏+]

标签:

Problem Description
输入两点坐标(X1,Y1),(X2,Y2),计算并输出两点间的距离。
 
Input
输入数据有多组,每组占一行,由4个实数组成,分别表示x1,y1,x2,y2,数据之间用空格隔开。
 
Output
对于每组输入数据,输出一行,结果保留两位小数。
 
Sample Input
0 0 0 1
0 1 1 0
 
Sample Output
1.00
1.41
 
题意:输入两点坐标(X1,Y1),(X2,Y2),计算并输出两点间的距离。
 
#include <stdio.h>
#include <math.h>
int main()
{
    double a, b, c, d, s;
    while (scanf ("%lf%lf%lf%lf", &a, &b, &c, &d)!=EOF)
    {
        s = sqrt((c-a)*(c-a)+(d-b)*(d-b));
        printf ("%.2lf\n", s);
        }
    return 0;
 }

 

HDU 2001 计算两点间的距离

标签:

原文地址:http://www.cnblogs.com/Noevon/p/5928334.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!