码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 4712 Hamming Distance 随机

时间:2016-10-05 12:49:26      阅读:123      评论:0      收藏:0      [点我收藏+]

标签:

Hamming Distance

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)


Problem Description
(From wikipedia) For binary strings a and b the Hamming distance is equal to the number of ones in a XOR b. For calculating Hamming distance between two strings a and b, they must have equal length.
Now given N different binary strings, please calculate the minimum Hamming distance between every pair of strings.
 

 

Input
The first line of the input is an integer T, the number of test cases.(0<T<=20) Then T test case followed. The first line of each test case is an integer N (2<=N<=100000), the number of different binary strings. Then N lines followed, each of the next N line is a string consist of five characters. Each character is ‘0‘-‘9‘ or ‘A‘-‘F‘, it represents the hexadecimal code of the binary string. For example, the hexadecimal code "12345" represents binary string "00010010001101000101".
 

 

Output
For each test case, output the minimum Hamming distance between every pair of strings.
 

 

Sample Input
2 2 12345 54321 4 12345 6789A BCDEF 0137F
 

 

Sample Output
6 7
 

 

Source
 

 思路:涨知识,还可以随机;

#include<bits/stdc++.h>
using namespace std;
#define ll long long
#define pi (4*atan(1.0))
#define eps 1e-14
const int N=1e5+10,M=4e6+10,inf=1e9+10,mod=1e9+7;
const ll INF=1e18+10;
int getnum(char a)
{
    if(a>=0&&a<=9)
        return a-0;
    return a-A+10;
}
int check(int x,int y)
{
    int sum=0;
    while(x||y)
    {
        if(x%2!=y%2)
        sum++;
        x>>=1;
        y>>=1;
    }
    return sum;
}
char ch[N][10];
int mp[20][20];
int main(){
    for(int i=0;i<16;i++)
    {
        for(int t=0;t<16;t++)
            mp[i][t]=check(i,t);
    }
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int x;
        scanf("%d",&x);
        for(int i=0;i<x;i++)
        scanf("%s",ch[i]);
        int ans=inf;
        for(int i=0;i<=1000000;i++)
        {
            int k=0;
            int n=rand()%x;
            int m=rand()%x;
            if(n==m)continue;
            for(int t=0;t<5;t++)
            k+=mp[getnum(ch[n][t])][getnum(ch[m][t])];
            ans=min(ans,k);
        }
        printf("%d\n",ans);
    }
    return 0;
}

 

hdu 4712 Hamming Distance 随机

标签:

原文地址:http://www.cnblogs.com/jhz033/p/5931903.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!