码迷,mamicode.com
首页 > 其他好文 > 详细

HDOJ 4941 Magical Forest

时间:2014-08-13 01:16:35      阅读:203      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   color   java   os   io   strong   


STL map 记录对应原图是第几行/列

Magical Forest

Time Limit: 24000/12000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 394    Accepted Submission(s): 188


Problem Description
There is a forest can be seen as N * M grid. In this forest, there is some magical fruits, These fruits can provide a lot of energy, Each fruit has its location(Xi, Yi) and the energy can be provided Ci. 

However, the forest will make the following change sometimes: 
1. Two rows of forest exchange. 
2. Two columns of forest exchange. 
Fortunately, two rows(columns) can exchange only if both of them contain fruits or none of them contain fruits. 

Your superior attach importance to these magical fruit, he needs to know this forest information at any time, and you as his best programmer, you need to write a program in order to ask his answers quick every time.
 

Input
The input consists of multiple test cases. 

The first line has one integer W. Indicates the case number.(1<=W<=5)

For each case, the first line has three integers N, M, K. Indicates that the forest can be seen as maps N rows, M columns, there are K fruits on the map.(1<=N, M<=2*10^9, 0<=K<=10^5)

The next K lines, each line has three integers X, Y, C, indicates that there is a fruit with C energy in X row, Y column. (0<=X<=N-1, 0<=Y<=M-1, 1<=C<=1000)

The next line has one integer T. (0<=T<=10^5)
The next T lines, each line has three integers Q, A, B. 
If Q = 1 indicates that this is a map of the row switching operation, the A row and B row exchange. 
If Q = 2 indicates that this is a map of the column switching operation, the A column and B column exchange. 
If Q = 3 means that it is time to ask your boss for the map, asked about the situation in (A, B). 
(Ensure that all given A, B are legal. )
 

Output
For each case, you should output "Case #C:" first, where C indicates the case number and counts from 1.

In each case, for every time the boss asked, output an integer X, if asked point have fruit, then the output is the energy of the fruit, otherwise the output is 0.
 

Sample Input
1 3 3 2 1 1 1 2 2 2 5 3 1 1 1 1 2 2 1 2 3 1 1 3 2 2
 

Sample Output
Case #1: 1 2 1
Hint
No two fruits at the same location.
 

Author
UESTC
 

Source
 


#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <map>

using namespace std;

typedef pair<int,int> pII;

map<pII,int> go;
map<int,int> hang;
map<int,int> lie;

int n,m,k,t;

int main()
{
    int T_T,cas=1;
    scanf("%d",&T_T);
    while(T_T--)
    {
        go.clear(); hang.clear(); lie.clear();
        scanf("%d%d%d",&n,&m,&k);
        for(int i=0;i<k;i++)
        {
            int x,y,c;
            scanf("%d%d%d",&x,&y,&c);
            go[make_pair(x,y)]=c;
            hang[x]=x; lie[y]=y;
        }
        scanf("%d",&t);
        printf("Case #%d:\n",cas++);
        while(t--)
        {
            int q,x,y;
            scanf("%d%d%d",&q,&x,&y);
            if(q==1)
            {
                int tx,ty;
                if(hang.count(x)==0)
                    hang[x]=x;
                tx=hang[x];

                if(hang.count(y)==0)
                    hang[y]=y;
                ty=hang[y];
                hang[x]=ty; hang[y]=tx;
            }
            else if(q==2)
            {
                int tx,ty;
                if(lie.count(x)==0)
                    lie[x]=x;
                tx=lie[x];

                if(lie.count(y)==0)
                    lie[y]=y;
                ty=lie[y];

                lie[x]=ty; lie[y]=tx;
            }
            else if(q==3)
            {
                int tx,ty;
                if(hang.count(x)==0)
                    tx=x;
                else tx=hang[x];
                if(lie.count(y)==0)
                    ty=y;
                else ty=lie[y];
                printf("%d\n",go[make_pair(tx,ty)]);
            }
        }
    }
    return 0;
}



HDOJ 4941 Magical Forest,布布扣,bubuko.com

HDOJ 4941 Magical Forest

标签:des   style   http   color   java   os   io   strong   

原文地址:http://blog.csdn.net/ck_boss/article/details/38523739

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!