码迷,mamicode.com
首页 > 其他好文 > 详细

Pat(Advanced Level)Practice--1060(Are They Equal)

时间:2014-05-08 02:07:49      阅读:452      评论:0      收藏:0      [点我收藏+]

标签:advance pat   基础题   科学计数法   

Pat1060代码

题目描述:

If a machine can save only 3 significant digits, the float numbers 12300 and 12358.9 are considered equal since they are both saved as 0.123*105 with simple chopping. Now given the number of significant digits on a machine and two float numbers, you are supposed to tell if they are treated equal in that machine.

Input Specification:

Each input file contains one test case which gives three numbers N, A and B, where N (<100) is the number of significant digits, and A and B are the two float numbers to be compared. Each float number is non-negative, no greater than 10100, and that its total digit number is less than 100.

Output Specification:

For each test case, print in a line "YES" if the two numbers are treated equal, and then the number in the standard form "0.d1...dN*10^k" (d1>0 unless the number is 0); or "NO" if they are not treated equal, and then the two numbers in their standard form. All the terms must be separated by a space, with no extra space at the end of a line.

Note: Simple chopping is assumed without rounding.

Sample Input 1:
3 12300 12358.9
Sample Output 1:
YES 0.123*10^5
Sample Input 2:
3 120 128
Sample Output 2:
NO 0.120*10^3 0.128*10^3

AC代码:
浮点数的科学计数法,纯字符串的比较;
下面是几个测试用例:

1.有前导0的情况 例如:

3 00000012.3 0000001.1
NO 0.123*10^2 0.11*10^1(太坑,一点提示也没有)

2.还有就是当位数不足N位时,不需要补全 , 如上的 0000001.1

3.0的不同表示,如:

5 0000000 0000000.000000
YES 0.00000*10^0

其实这题有些搞笑, 如下:

4   00000012.0 0000012.00
NO 0.120*10^2 0.1200*10^2

同样是0.12不相等。。。  纯字符串比较,题目要求不删除小数部分的后导0

#include<cstdio>
#include<cstring>
#define MAX 105

using namespace std;

int Process(char str[],int n,char ret[])
{
	int i=0,j=0;
	int exp=0;
	while(str[i]==‘0‘)//去掉前面的0
		i++;
	if(str[i]==‘.‘)//型如0000000.000*****的浮点数
	{
		i++;
		while(str[i]==‘0‘)
		{
			i++;
			exp--;
		}
		if(str[i]==‘\0‘)//0的另一种形式如00000.000000
		{
			int k;
			exp=0;
			for(k=0;k<n;k++)
				ret[k]=‘0‘;
			ret[k]=‘\0‘;
			return exp;
		}
		while(str[i]!=‘\0‘)
		{
			ret[j]=str[i];
			i++;
			j++;
			if(j==n)
				break;
		}
	}
	else
	{
		if(str[i]==‘\0‘)//0的一种表示例如00000000
		{
			int k;
			exp=0;
			for(k=0;k<n;k++)
				ret[k]=‘0‘;
			ret[k]=‘\0‘;
			return exp;
		}
		else//0000*****.******
		{
			while(str[i]!=‘.‘&&str[i]!=‘\0‘)
			{
				if(j<n)//取n位的精度
				{
					ret[j]=str[i];
					j++;
				}
				i++;
				exp++;
			}
			if(j<n&&str[i]!=‘\0‘)
			{
				i++;
				while(str[i]!=‘\0‘)
				{
					ret[j]=str[i];
					i++;
					j++;
					if(j==n)
						break;
				}
			}
		}
	}
	ret[j]=‘\0‘;
	return exp;
}

int main(int argc,char *argv[])
{
	int N;
	char A[MAX],B[MAX];
	scanf("%d %s %s",&N,A,B);
	char retA[MAX],retB[MAX];
	int expA=Process(A,N,retA);
	int expB=Process(B,N,retB);
	if(expA==expB&&strcmp(retA,retB)==0)
		printf("YES 0.%s*10^%d\n",retA,expA);
	else
		printf("NO 0.%s*10^%d 0.%s*10^%d\n",retA,expA,retB,expB);
	
	return 0;
}


Pat(Advanced Level)Practice--1060(Are They Equal),布布扣,bubuko.com

Pat(Advanced Level)Practice--1060(Are They Equal)

标签:advance pat   基础题   科学计数法   

原文地址:http://blog.csdn.net/cstopcoder/article/details/25245819

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!