码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 5907 Find Q(字符串)

时间:2016-10-07 11:27:10      阅读:151      评论:0      收藏:0      [点我收藏+]

标签:

传送门

Description

Byteasar is addicted to the English letter ‘q‘. Now he comes across a string S consisting of lowercase English letters.

He wants to find all the continous substrings of S, which only contain the letter ‘q‘. But this string is really really long, so could you please write a program to help him?

Input

The first line of the input contains an integer T(1≤T≤10), denoting the number of test cases.

In each test case, there is a string S, it is guaranteed that S only contains lowercase letters and the length of S is no more than 100000.

Output

For each test case, print a line with an integer, denoting the number of continous substrings of S, which only contain the letter ‘q‘.

Sample Input

2
qoder
quailtyqqq

Sample Output

1
7

思路

题意找出SS的所有仅包含字母‘q‘的连续子串

只要求出每个位置能往右延伸多长即可。

 
#include<cstdio>
#include<cstring>
using namespace std;
const int maxn = 100005;
char a[maxn];

int main()
{
    int T;
    scanf("%d",&T);
    while (T--)
    {
        __int64 res = 0,cnt = 0;
        scanf("%s",a);
        int len = strlen(a);
        for (int i = 0;i < len;)
        {
            if (a[i] == ‘q‘)
            {
                while (a[i] == ‘q‘)
                {
                    i++;
                    cnt++;
                }
                res += (1+cnt)*cnt/2;
                cnt = 0;
            }
            else
            {
                i++;
            }
        }
        printf("%I64d\n",res);
    }
    return 0;
}

  

  

HDU 5907 Find Q(字符串)

标签:

原文地址:http://www.cnblogs.com/zzy19961112/p/5935563.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!