码迷,mamicode.com
首页 > 其他好文 > 详细

poj1961 & hdu 1358 Period(KMP)

时间:2014-08-13 10:34:15      阅读:229      评论:0      收藏:0      [点我收藏+]

标签:kmp   hdu   poj   

poj 题目链接:http://poj.org/problem?id=1961

hdu题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1358


Description

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK ,that is A concatenated K times, for some string A. Of course, we also want to know the period K.

Input

The input consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.The second line contains the string S. The input file ends with a line, having the 
number zero on it.

Output

For each test case, output "Test case #" and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

Sample Input

3
aaa
12
aabaabaabaab
0

Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

Source


题意:

给出一个字符串,求这个字符串到第i个字符为止的循环节的次数。

比如aabaabaabaab,长度为12.到第二个a时,a出现2次,输出2.到第二个b时,aab出现了2次,输出2.到第三个b时,aab出现3次,输出3.到第四个b时,aab出现4次,输出4.


代码如下:

#include<cstdio>
#include<cstring>
#include<string>
#define N 1000017
int next[N];
int len;
void getnext(char s[])
{
    int i = 0, j = -1;
    next[0] = -1;
    while(i < len)
    {
        if(j == -1 || s[i] == s[j])
        {
            i++;
            j++;
            next[i] = j;
        }
        else
            j = next[j];
    }
}
int main()
{
    char s[N];
    int cas = 0;
    int length;
    while(scanf("%d", &len) && len)
    {
        scanf("%s", s);
        getnext(s);
        printf("Test case #%d\n", ++cas);
        for(int i = 1; i <= len; i++)
        {
            length = i - next[i];//循环节的长度
            if(i != length && i % length == 0)//如果有多个循环 
                printf("%d %d\n", i, i / length);
        }
        printf("\n");
    }
    return 0;
}



poj1961 & hdu 1358 Period(KMP),布布扣,bubuko.com

poj1961 & hdu 1358 Period(KMP)

标签:kmp   hdu   poj   

原文地址:http://blog.csdn.net/u012860063/article/details/38532145

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!