码迷,mamicode.com
首页 > 其他好文 > 详细

An easy problem

时间:2016-10-09 22:52:08      阅读:157      评论:0      收藏:0      [点我收藏+]

标签:

One day Teddy met a old man in his dream , in that dream the man whose name was“RuLai” gave Teddy a problem : 

Given an N , can you calculate how many ways to write N as i * j + i + j (0 < i <= j) ? 

Teddy found the answer when N was less than 10…but if N get bigger , he found it was too difficult for him to solve. 
Well , you clever ACMers ,could you help little Teddy to solve this problem and let him have a good dream ? 

Input

The first line contain a T(T <= 2000) . followed by T lines ,each line contain an integer N (0<=N <= 10 10).

Output

For each case, output the number of ways in one line.

Sample Input

2
1
3

Sample Output

0
1






#include<cstdio>
#include<cmath>
#include<iostream>
using namespace std;
int main()
{
	int T;
	scanf("%d",&T);
	while(T--)
	{
		int ans=0;
		long long N;
		scanf("%lld",&N);
		/*for(int i=1;(i+1)*(i+1)<=(N+1);i++)
		{
			if(((N-i)%(i+1)==0)&&((N-i)/(i+1)>=i))
				ans++;
		}*/
		for(long long i=1;(i+1)*(i+1)<=(N+1);i++)
		{
			if((N+1)%(i+1)==0&&((N-i)/(i+1)>=i))
				ans++;
		}
		printf("%d\n",ans);
	}
	return 0;
 } 

An easy problem

标签:

原文地址:http://www.cnblogs.com/-xss/p/5943987.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!