码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1078 FatMouse and Cheese(记忆化)

时间:2014-08-13 14:56:46      阅读:236      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   color   os   io   for   ar   

Problem Description
FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he‘s going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move. 
 

Input
There are several test cases. Each test case consists of 

a line containing two integers between 1 and 100: n and k 
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on. 
The input ends with a pair of -1‘s. 
 

Output
For each test case output in a line the single integer giving the number of blocks of cheese collected. 
 

Sample Input
3 1 1 2 5 10 11 6 12 12 7 -1 -1
 

Sample Output
37
 

Source
 
写了几道记忆化。dp[i][j]里存的是i,j位置开始搜的时候的合法状态。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<limits.h>
using namespace std;
const int maxn=110;
int mp[maxn][maxn];
int dp[maxn][maxn];
int n,k;
int dr[4][2]={{-1,0},{1,0},{0,1},{0,-1}};
bool ok(int x,int y)
{
     if(x>=0&&x<n&&y>=0&&y<n)
        return true;
     else
        return false;
}
int fun(int x,int y)
{
    int temp,minn=0;
    if(dp[x][y]>0)
        return dp[x][y];
    for(int i=0;i<4;i++)
    {
        for(int j=1;j<=k;j++)
        {
            int xx=x+dr[i][0]*j;
            int yy=y+dr[i][1]*j;
            if(ok(xx,yy)&&mp[x][y]<mp[xx][yy])
            {
                temp=fun(xx,yy);
                if(temp>minn)
                    minn=temp;
            }
        }
    }
    return dp[x][y]=minn+mp[x][y];
}
int main()
{
   while(~scanf("%d%d",&n,&k))
   {
       if(n==-1&&k==-1)
          break;
       for(int i=0;i<n;i++)
       {
           for(int j=0;j<n;j++)
            scanf("%d",&mp[i][j]);
       }
       memset(dp,0,sizeof(dp));
       printf("%d\n",fun(0,0));
   }
   return 0;
}


HDU 1078 FatMouse and Cheese(记忆化),布布扣,bubuko.com

HDU 1078 FatMouse and Cheese(记忆化)

标签:des   style   http   color   os   io   for   ar   

原文地址:http://blog.csdn.net/u013582254/article/details/38536385

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!