码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 2398 - Toy Storage

时间:2016-10-14 20:51:14      阅读:159      评论:0      收藏:0      [点我收藏+]

标签:

Toy Storage
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 5439   Accepted: 3234

Description

Mom and dad have a problem: their child, Reza, never puts his toys away when he is finished playing with them. They gave Reza a rectangular box to put his toys in. Unfortunately, Reza is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for Reza to find his favorite toys anymore. 
Reza‘s parents came up with the following idea. They put cardboard partitions into the box. Even if Reza keeps throwing his toys into the box, at least toys that get thrown into different partitions stay separate. The box looks like this from the top: 
技术分享

We want for each positive integer t, such that there exists a partition with t toys, determine how many partitions have t, toys.

Input

The input consists of a number of cases. The first line consists of six integers n, m, x1, y1, x2, y2. The number of cardboards to form the partitions is n (0 < n <= 1000) and the number of toys is given in m (0 < m <= 1000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1, y1) and (x2, y2), respectively. The following n lines each consists of two integers Ui Li, indicating that the ends of the ith cardboard is at the coordinates (Ui, y1) and (Li, y2). You may assume that the cardboards do not intersect with each other. The next m lines each consists of two integers Xi Yi specifying where the ith toy has landed in the box. You may assume that no toy will land on a cardboard. 

A line consisting of a single 0 terminates the input.

Output

For each box, first provide a header stating "Box" on a line of its own. After that, there will be one line of output per count (t > 0) of toys in a partition. The value t will be followed by a colon and a space, followed the number of partitions containing t toys. Output will be sorted in ascending order of t for each box.

Sample Input

4 10 0 10 100 0
20 20
80 80
60 60
40 40
5 10
15 10
95 10
25 10
65 10
75 10
35 10
45 10
55 10
85 10
5 6 0 10 60 0
4 3
15 30
3 1
6 8
10 10
2 1
2 8
1 5
5 5
40 10
7 9
0

Sample Output

Box
2: 5
Box
1: 4
2: 1

Source

我的“第一道”计算几何题=ω=

判断点在直线的哪一侧,机智地用了叉积

技术分享

叉积同号代表在直线同侧,异号则在异侧,在直线上则为零。

//POJ 2398
//利用叉积判断点与直线位置关系
//C++11特性在ACM中不能用
//AC 2016.10.12

#include "cstdio"
#include "cstdlib"
#include "cmath"
#include "cstring"
#include "iostream"
#define MAXN 5010
#define MAXM 5010
using namespace std;
const double eps = 1E-8;

int sgn(double x){
    return (fabs(x)<eps)?0:((x>0)?1:-1);
}

struct point{
    double x, y;
    point (){}
    point (double X, double Y): x(X), y(Y){}
    point operator - (const point &p){
        return point(x - p.x, y - p.y);
    }
    double operator ^ (const point &p){
        return x * p.y - y * p.x;
    }
}toys[MAXM];

struct line {
    point p1, p2;
    line (){}
    line (point P1, point P2): p1(P1), p2(P2) {}
}lines[MAXN];

template <typename T>
void swp(T &l1, T &l2){
    T l = l1;
    l1 = l2;
    l2 = l;
}

template <typename T>
void BubbleSort(T arr[], int n, bool (*cmp)(T, T)){
    for (int i = 0; i < n; i++){
        for (int j = 0; j < i; j++){
            if (!cmp(arr[j], arr[i]))
                swp<T>(arr[j], arr[i]);
        }
    }
}

bool cmpline(line l1, line l2){
    return l1.p1.x <= l2.p1.x;
}

bool cmpint(int a, int b){
    return a <= b;
}

int n, m, X1, Y1, X2, Y2;
int ans[MAXN];
int main(){
    freopen("fin.c", "r", stdin);
    while (scanf("%d%d%d%d%d%d", &n, &m, &X1, &Y1, &X2, &Y2)){
        if (!n) break;
        puts("Box");
        memset(ans, 0, sizeof (ans));
        lines[0] = line(point(X1, Y1), point(X1, Y2));
        for (int i = 1; i <= n; i++){
            int u, l;
            scanf("%d%d", &u, &l);
            lines[i] = line(point(u, Y1), point(l, Y2));
        }
        lines[n + 1] = line(point(X2, Y1), point(X2, Y2));
        BubbleSort<line>(lines, n + 2, cmpline);
        for (int i = 0; i < m; i++){
            int x, y;
            scanf("%d%d", &x, &y);
            toys[i] = point(x, y);
            for (int j = 0; j <= n; j++){
                double d1 = (lines[j].p2 - lines[j].p1) ^ (toys[i] - lines[j].p1);
                double d2 = (lines[j + 1].p2 - lines[j + 1].p1) ^ (toys[i] - lines[j + 1].p1);
                if (sgn(d1) != sgn(d2)){
                    ans[j]++;
                    break;
                }
            }
        }
        int avr = m/(n + 1);
        BubbleSort<int>(ans, n + 1, cmpint);
        for (int i = 0, cnt = 0, old = ans[0];
            i <= n;
            i++, cnt++, (ans[i] == old)?0:(old?printf("%d: %d\n", old, cnt):0, cnt = 0), old = ans[i]);
        //puts("");
    }
    getchar();
    return 0;
}

POJ 2398 - Toy Storage

标签:

原文地址:http://www.cnblogs.com/xlnx/p/5961851.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!