标签:
本题要求计算A/B,其中A是不超过1000位的正整数,B是1位正整数。你需要输出商数Q和余数R,使得A = B * Q + R成立。
输入格式:
输入在1行中依次给出A和B,中间以1空格分隔。
输出格式:
在1行中依次输出Q和R,中间以1空格分隔。
输入样例:123456789050987654321 7输出样例:
17636684150141093474 3
#include <iostream>
#include <string>
using namespace std;
int main()
{
string a;
int b, i, first = 0, temp = 0;
cin >> a >> b;
for (i = 0; i<a.length(); i++)
{
temp = temp * 10 + a[i] - 48;
if (temp >= b)
{
cout << temp / b;
first = 1;
}
else if (first) cout << 0;
temp = temp%b;
}
if (first == 0) cout << 0;
cout << " " << temp << endl;
system("pause");
return 0;
}
标签:
原文地址:http://www.cnblogs.com/code666/p/5961971.html