码迷,mamicode.com
首页 > 其他好文 > 详细

CodeForces 731C C - Socks 并查集

时间:2016-10-17 07:08:21      阅读:262      评论:0      收藏:0      [点我收藏+]

标签:

Description

Arseniy is already grown-up and independent. His mother decided to leave him alone for m days and left on a vacation. She have prepared a lot of food, left some money and washed all Arseniy‘s clothes.

Ten minutes before her leave she realized that it would be also useful to prepare instruction of which particular clothes to wear on each of the days she will be absent. Arseniy‘s family is a bit weird so all the clothes is enumerated. For example, each of Arseniy‘s n socks is assigned a unique integer from 1 to n. Thus, the only thing his mother had to do was to write down two integers li and ri for each of the days — the indices of socks to wear on the day i (obviously, li stands for the left foot and ri for the right). Each sock is painted in one of k colors.

When mother already left Arseniy noticed that according to instruction he would wear the socks of different colors on some days. Of course, that is a terrible mistake cause by a rush. Arseniy is a smart boy, and, by some magical coincidence, he posses k jars with the paint — one for each of k colors.

Arseniy wants to repaint some of the socks in such a way, that for each of m days he can follow the mother‘s instructions and wear the socks of the same color. As he is going to be very busy these days he will have no time to change the colors of any socks so he has to finalize the colors now.

The new computer game Bota-3 was just realised and Arseniy can‘t wait to play it. What is the minimum number of socks that need their color to be changed in order to make it possible to follow mother‘s instructions and wear the socks of the same color during each of m days.

Input

The first line of input contains three integers n, m and k (2?≤?n?≤?200?000, 0?≤?m?≤?200?000, 1?≤?k?≤?200?000) — the number of socks, the number of days and the number of available colors respectively.

The second line contain n integers c1, c2, ..., cn (1?≤?ci?≤?k) — current colors of Arseniy‘s socks.

Each of the following m lines contains two integers li and ri (1?≤?li,?ri?≤?n, li?≠?ri) — indices of socks which Arseniy should wear during the i-th day.

Output

Print one integer — the minimum number of socks that should have their colors changed in order to be able to obey the instructions and not make people laugh from watching the socks of different colors.

Sample Input

Input
3 2 3
1 2 3
1 2
2 3
Output
2
Input
3 2 2
1 1 2
1 2
2 1
Output
0

Sample Output

 

Hint

In the first sample, Arseniy can repaint the first and the third socks to the second color.

In the second sample, there is no need to change any colors.

 

比较简单的并查集。

思路就是,因为它说[L, R]是同一个颜色。那就合并起来。

然后对于并查集的每段区间里面的数。都有各自的颜色,贪心去变成颜色出现最多那个就行了。

就是用并查集把他们分组了。

没一组都要相同颜色。那么本来有2号颜色是最多的话。那么其它都要变成2号颜色。

技术分享
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <algorithm>
using namespace std;
#define inf (0x3f3f3f3f)
typedef long long int LL;

#include <iostream>
#include <sstream>
#include <vector>
#include <set>
#include <map>
#include <queue>
#include <string>
const int maxn = 200000 + 20;
int fa[maxn];
int colors[maxn];
vector<int>pos[maxn];
int find(int u) {
    if (fa[u] == u) {
        return fa[u];
    } else return fa[u] = find(fa[u]);
}
void merge(int x, int y) {
    x = find(x);
    y = find(y);
    if (x != y) {
        fa[y] = x;
    }
}
int book[maxn];
void work() {
    for (int i = 1; i <= maxn - 2; ++i) fa[i] = i;
    int n, m, k;
    scanf("%d%d%d", &n, &m, &k);
    for (int i = 1; i <= n; ++i) {
        scanf("%d", &colors[i]);
    }
    for (int i = 1; i <= m; ++i) {
        int L, R;
        scanf("%d%d", &L, &R);
        merge(L, R);
    }
    for (int i = 1; i <= n; ++i) {
        pos[find(i)].push_back(i);
    }
    int ans = 0;
    for (int i = 1; i <= n; ++i) {
        if (pos[i].size() == 0) continue;
        for (int j = 0; j < pos[i].size(); ++j) {
            book[colors[pos[i][j]]]++;
        }
        int mx = -inf;
        for (int j = 0; j < pos[i].size(); ++j) {
            mx = max(book[colors[pos[i][j]]], mx);
            book[colors[pos[i][j]]] = 0;
        }
//        memset(book, 0, sizeof book);
        ans += pos[i].size() - mx;
    }
    cout << ans << endl;
}
int main() {
#ifdef local
    freopen("data.txt","r",stdin);
#endif
    work();
    return 0;
}
View Code

 

CodeForces 731C C - Socks 并查集

标签:

原文地址:http://www.cnblogs.com/liuweimingcprogram/p/5968238.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!