码迷,mamicode.com
首页 > 其他好文 > 详细

poj 1979 && zoj 2165 Red and Black

时间:2014-08-13 22:04:17      阅读:266      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   color   os   io   strong   for   

Red and Black
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 22409   Accepted: 12100

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can‘t move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

‘.‘ - a black tile 
‘#‘ - a red tile 
‘@‘ - a man on a black tile(appears exactly once in a data set) 
The end of the input is indicated by a line consisting of two zeros. 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

 

 

 

             一道简单的DFS题,统计可以搜索的个数。题意:一男子站在一个黑色的瓷砖上,他旁边有黑色和红色的瓷砖,但他只能走黑色的瓷砖,而且是4个方向,问他最多能走多少个黑色的瓷砖。

 

#include <stdio.h>
#include <string.h>
#include <iostream>
using namespace std;

int num;
char map[25][25];
int visited[25][25];
int dir[4][2] = {0, -1, 1, 0, 0, 1, -1, 0};

void DFS(int x, int y, int n, int m)
{
    int mx, my;
    for(int i = 0; i<4; i++)
    {
        mx = x+dir[i][0];    my = y+dir[i][1];
        if(mx>=1 && mx<=n && my>=1 && my<=m && !visited[mx][my] && map[mx][my]==.)
        {
            visited[mx][my] = 1;
            num++;
            DFS(mx, my, n, m);
        }
    }
}

int main()
{
    int n, m, x, y;
    while(scanf("%d%d", &m, &n)!=EOF && (n || m))
    {
        num = 1;
        memset(visited, 0, sizeof(visited));
        for(int i = 1; i<=n; i++)
        {
            for(int j = 1; j<=m; j++)
            {
                cin>>map[i][j];
                if(map[i][j] == @)
                {
                    x = i;
                    y = j;
                    visited[x][y] = 1;
                }
            }
        }

        DFS(x, y, n, m);
        printf("%d\n", num);
    }

    return 0;
}

 

poj 1979 && zoj 2165 Red and Black,布布扣,bubuko.com

poj 1979 && zoj 2165 Red and Black

标签:des   style   blog   color   os   io   strong   for   

原文地址:http://www.cnblogs.com/fengxmx/p/3910876.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!