码迷,mamicode.com
首页 > 其他好文 > 详细

HDU3466 背包DP

时间:2016-10-20 21:39:20      阅读:194      评论:0      收藏:0      [点我收藏+]

标签:

Proud Merchants

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 5566    Accepted Submission(s): 2345


Problem Description
Recently, iSea went to an ancient country. For such a long time, it was the most wealthy and powerful kingdom in the world. As a result, the people in this country are still very proud even if their nation hasn’t been so wealthy any more.
The merchants were the most typical, each of them only sold exactly one item, the price was Pi, but they would refuse to make a trade with you if your money were less than Qi, and iSea evaluated every item a value Vi.
If he had M units of money, what’s the maximum value iSea could get?

 

 

Input
There are several test cases in the input.

Each test case begin with two integers N, M (1 ≤ N ≤ 500, 1 ≤ M ≤ 5000), indicating the items’ number and the initial money.
Then N lines follow, each line contains three numbers Pi, Qi and Vi (1 ≤ Pi ≤ Qi ≤ 100, 1 ≤ Vi ≤ 1000), their meaning is in the description.

The input terminates by end of file marker.

 

 

Output
For each test case, output one integer, indicating maximum value iSea could get.

 

 

Sample Input
2 10
10 15 10
5 10 5
3 10
5 10 5
3 5 6
2 7 3
 

 

Sample Output
5
11
 

 

Author
iSea @ WHU
 

 

Source
 
题意:
买一件价格为p的物品时手里的钱不少于p时才能购买。给出n件物品的p,q,v,v代表价值,总钱数m,问最大能够买到多大的价值。
代码:
//先买q大而p小的比较好,所以按照q-p排序,注意是从小到大排序,因为背包公式中
//f[i]=max(f[i],f[i-m]+v)是假设i-m被装满时再装下一件,是假设倒着装的。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int f[5005];
int n,m;
struct proud
{
    int p,q,v,ch;
};
bool cmp(proud a,proud b)
{
    return a.ch<b.ch;
}
/*void zeroonepack(int v,int m,int ttl)
{
    for(int i=ttl;i>=v;i--)
    f[i]=max(f[i],f[i-v]+m);
}
void complitpack(int v,int m,int ttl)
{
    for(int i=v;i<=ttl;i++)
    f[i]=max(f[i],f[i-v]+m);
}
void multipack(int v,int m,int c,int ttl)
{
    if(c*v>=ttl)
    complitpack(v,m,ttl);
    else
    {
        int k=1;
        while(k<c)
        {
            zeroonepack(k*v,k*m,ttl);
            c-=k;
            k*=2;
        }
        zeroonepack(c*v,c*m,ttl);
    }
}*/
int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        memset(f,0,sizeof(f));
        proud pr[505];
        for(int i=1;i<=n;i++)
        {
            scanf("%d%d%d",&pr[i].p,&pr[i].q,&pr[i].v);
            pr[i].ch=pr[i].q-pr[i].p;
        }
        sort(pr+1,pr+n+1,cmp);
        for(int i=1;i<=n;i++)
        {
            for(int j=m;j>=pr[i].q;j--)
            {
                f[j]=max(f[j],f[j-pr[i].p]+pr[i].v);
            }
        }
        int ans=0;
        printf("%d\n",f[m]);
    }
    return 0;
}

 

HDU3466 背包DP

标签:

原文地址:http://www.cnblogs.com/--ZHIYUAN/p/5982485.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!