码迷,mamicode.com
首页 > 其他好文 > 详细

nyist 242 计算球体积

时间:2014-08-13 22:19:57      阅读:257      评论:0      收藏:0      [点我收藏+]

标签:style   blog   http   color   os   io   strong   数据   

题目242
题目信息运行结果本题排行讨论区计算球体积
时间限制:3000 ms | 内存限制:65535 KB
难度:1
描述
根据输入的半径值,计算球的体积。
输入
输入数据有多组,每组占一行,每行包括一个实数,表示球的半径。(0<R<100)
输出
输出对应的球的体积,对于每组输入数据,输出一行,计算结果四舍五入为整数
Hint:PI=3.1415926
样例输入
1
1.5样例输出
4
14

 

bubuko.com,布布扣
#include<stdio.h>
#include <iostream>
using namespace std;
#define PI 3.1415926
int main()
{
double r;
int v;

while(cin>>r)
{

v=int( (4*PI*r*r*r)/3 + 0.5 );
cout<<v<<endl;
}
}

 

 

 

 

 bubuko.com,布布扣

 

#include <iostream>
#include <stdio.h>
using namespace std;

#define PI 3.1415926
int main()
{
double r,V;
while(cin>>r)
{
V=4.0/3.0*PI*r*r*r;
printf("%.0f\n",V);
}
return 0;
}

nyist 242 计算球体积,布布扣,bubuko.com

nyist 242 计算球体积

标签:style   blog   http   color   os   io   strong   数据   

原文地址:http://www.cnblogs.com/2014acm/p/3911174.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!