码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 2777 Count Color (线段树区间更新加查询)

时间:2014-08-13 22:28:57      阅读:401      评论:0      收藏:0      [点我收藏+]

标签:des   style   color   os   io   ar   div   代码   

Description

Chosen Problem Solving and Program design as an optional course, you are required to solve all kinds of problems. Here, we get a new problem.

There is a very long board with length L centimeter, L is a positive integer, so we can evenly divide the board into L segments, and they are labeled by 1, 2, ... L from left to right, each is 1 centimeter long. Now we have to color the board - one segment with only one color. We can do following two operations on the board:

1. "C A B C" Color the board from segment A to segment B with color C.
2. "P A B" Output the number of different colors painted between segment A and segment B (including).

In our daily life, we have very few words to describe a color (red, green, blue, yellow…), so you may assume that the total number of different colors T is very small. To make it simple, we express the names of colors as color 1, color 2, ... color T. At the beginning, the board was painted in color 1. Now the rest of problem is left to your.

Input

First line of input contains L (1 <= L <= 100000), T (1 <= T <= 30) and O (1 <= O <= 100000). Here O denotes the number of operations. Following O lines, each contains "C A B C" or "P A B" (here A, B, C are integers, and A may be larger than B) as an operation defined previously.

Output

Ouput results of the output operation in order, each line contains a number.

Sample Input

2 2 4
C 1 1 2
P 1 2
C 2 2 2
P 1 2

Sample Output

2
1



看了网上不少的题解,感觉没有那么麻烦。。就是区间更新,每次统计数量的时候哈希一下就好,详见代码。


#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <math.h>
#include <ctype.h>
#define lson o << 1, l, m
#define rson o << 1|1, m+1, r
using namespace std;
typedef long long LL;
const int MAX = 0x3f3f3f3f;
const int maxn = 100010;
int n, a, b, c, t, q, ans;
char s[3];
int cnt[maxn<<2], vis[35];
void down(int o) {
    if(cnt[o]) {
        cnt[o<<1] = cnt[o<<1|1] = cnt[o];
        cnt[o] = 0;
    }
}
void build(int o, int l, int r) {
    cnt[o] = 1;
    if(l == r) return;
    int m = (l+r) >> 1;
    build(lson);
    build(rson);
}
void update(int o, int l, int r) {
    if(a <= l && r <= b) {
        cnt[o] = c;
        return;
    }
    down(o);
    int m = (l+r) >> 1;
    if(a <= m) update(lson);
    if(m < b ) update(rson);
}
void query(int o, int l, int r) {
    if(cnt[o]) {
        if(vis[ cnt[o] ] == 0) {
            ans ++;
            vis[ cnt[o] ] = 1;
        }
        return ;
    }
    int m = (l+r) >> 1;
    if(a <= m) query(lson);
    if(m < b ) query(rson);
}
int main()
{
    scanf("%d%d%d", &n, &t, &q);
    build(1, 1, n);
    while(q--) {
        scanf("%s%d%d", s, &a, &b);
        if(a > b) swap(a, b);
        if(s[0] == 'C') {
            scanf("%d", &c);
            update(1, 1, n);
        } else {
            memset(vis, 0, sizeof(vis));
            ans = 0;
            query(1, 1, n);
            printf("%d\n", ans);
        }
    }
    return 0;
}



POJ 2777 Count Color (线段树区间更新加查询),布布扣,bubuko.com

POJ 2777 Count Color (线段树区间更新加查询)

标签:des   style   color   os   io   ar   div   代码   

原文地址:http://blog.csdn.net/u013923947/article/details/38542633

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!